Closed Bug 1409347 Opened 2 years ago Closed 2 years ago

[Form Autofill] Credit card autofill does not work on all fields using newegg

Categories

(Toolkit :: Form Autofill, defect, P3, major)

defect

Tracking

()

RESOLVED WORKSFORME
Tracking Status
firefox-esr52 --- unaffected
firefox56 --- unaffected
firefox57 --- unaffected
firefox58 --- wontfix
firefox59 --- affected

People

(Reporter: bogdan_maris, Assigned: selee)

References

()

Details

(Whiteboard: [form autofill:V2][Misc.])

Attachments

(1 file)

[Affected versions]:
- Firefox 57 beta 9
- latest Nightly 58.0a1

[Affected platforms]:
- macOS 10.12.6
- Windows 10 64bit
- Ubuntu 14.04 32bit

[Steps to reproduce]:
1. Start Firefox
2. Create a Credit Card address from about:preferences#privacy
3. Visit newegg and login with a test account
4. Proceed to checkout 
5. Select Credit Card from Payment Methods
6. Double click on Credit Card fields
7. Select Newegg Store Credit Card from Payment Methods
8. Double click on Credit Number field
9. Click outside of the field so 'This field is required' appears
10. Double click again in Credit Number field

[Expected result]:
- Form autofill for credit card appears in all the files that contain credit card information.

[Actual result]:
- Form autofill does not work on some fields.

[Regression range]:
- Not sure if this is a regression, will investigate further asap.

[Additional notes]:
- Here is a video showing the issue. The file was to large to upload it directly in bugzilla: https://www.dropbox.com/s/i8c4o29b1jgfcj1/newegg%20credit%20card.mov?dl=0
Severity: normal → major
This is about the section issue and we are going to implement the section support in V2 phase.
According to comment 1, it's a known issue and can't be fixed within MVP's scope. Let's move it to V2 scope.
Whiteboard: [form autofill] → [form autofill:V2]
Bogdan, did you force credit card support on in beta with extensions.formautofill.creditCards.available? It should be disabled there (I confirmed in a new profile)
Flags: needinfo?(bogdan.maris)
Priority: -- → P3
(In reply to Matthew N. [:MattN] (huge backlog; PM if requests are blocking you) from comment #3)
> Bogdan, did you force credit card support on in beta with
> extensions.formautofill.creditCards.available? It should be disabled there
> (I confirmed in a new profile)

Yes I did. Indeed Credit Card is disabled in beta.
Flags: needinfo?(bogdan.maris)
Credit Card support is disabled by default on Fx57
Component: Form Manager → Form Autofill
We're going to fix it in Fx59 by implementing section support.
Whiteboard: [form autofill:V2] → [form autofill:V2][Misc.]
Firefox 58 beta 5, Ubuntu 16.04 64-bit, https://www-ssl.bestbuy.com/checkout page:
- double click on Credit Card or Debit Card field and select a valid CC -> CC field is filled, Expiration and Security Code fields are shown - but left blank
There are multiple options in the payment page of NewEgg, and "Credit Card/ADD NEW CREDIT CARD" section can be filled with the patch in bug 1416664.

In addition, "Newegg Store Credit Card" section can not be filled since it's without cc-exp* fields. (see bug 1400760 in detail)
Depends on: 1416664
Hi Ovidiu, can you please to report that steps you do to reproduce this bug ? Thanks.
Flags: needinfo?(ovidiu.boca)
Hi Sean, QA Ovidiu report that with the build Nightly 59.0a1(2017-12-05) the bug still happens, can you help to verify it?
Flags: needinfo?(selee)
Hi Lauren,

I tried to verify NewEgg.com on the commit [1], and it works. Please see comment 8 as well in detail.

[1] https://reviewboard-hg.mozilla.org/gecko/rev/f2cf6d1473808039be5ecd8727cc3791d5d7d2d4
Flags: needinfo?(selee)
Ooh, leave the ni for tracking by myself.
Flags: needinfo?(selee)
We tested on Mac Os X 10.13, 10.11, Windows 7 10 and Ubuntu 16.04, we followed the steps from description:

STR:
1. Start Firefox
2. Create a Credit Card address from about:preferences#privacy
3. Visit newegg and login with a test account
4. Proceed to checkout 
5. Select Credit Card from Payment Methods
6. Double click on Credit Card fields
7. Select Newegg Store Credit Card from Payment Methods
8. Double click on Credit Number field

Actual result: 

Sometimes there is no drop-down displayed and in other cases, we see a drop-down with credit cards suggestions but we can't select any of them. 

Expected result:

Form autofill for credit card appears in all the files that contain credit card information and you can select.

NOTE: Please see the attached video.
Flags: needinfo?(ovidiu.boca)
Hi Ovidiu,

Do you mean "Newegg Store Credit Card" can not be filled by FormAutofill feature?

If so, this is an expected behavior based on the discussion of bug 1400760. Please see comment 8 and "Newegg Store Credit Card" section can NOT be filled since it's without cc-exp* fields.

For any credit section,
1. any cc-number is detected by `autocomplete` attr, and Firefox should help to fill it.
2. If `cc-number` field is detected by heuristics, Firefox should help to fill it once the section contains cc-exp* fields.

For the case of "Newegg Store Credit Card", it is without cc-exp* field in its section just like the rule 2.

For "Credit Card/ADD NEW CREDIT CARD" section, even it's cc-number without autocomplete attr, the section still contains cc-exp-year and cc-exp-month. That's why it works.

Please let me know if you have any concern. Thank you.
Flags: needinfo?(selee)
Hi Sean,

Yes, I'm referring to "Newegg Store Credit Card" cannot be filled by FormAutofill feature", from what I see this is the expected result.
Per comment 14 and 15, we can close this issue since the multiple section feature is landed.
Assignee: nobody → selee
Status: NEW → RESOLVED
Closed: 2 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.