'Store Data in Persistent Storage' setting resets after clearing site data from pref page

RESOLVED DUPLICATE of bug 1348223

Status

()

defect
RESOLVED DUPLICATE of bug 1348223
2 years ago
2 years ago

People

(Reporter: erdbanfed, Unassigned)

Tracking

58 Branch
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

User Agent: Mozilla/5.0 (Windows NT 6.1; Win64; x64; rv:52.0) Gecko/20100101 Firefox/52.0
Build ID: 20100101

Steps to reproduce:

1. Went on YouTube
2. Opened the Page Info dialogue
3. Blocked the storing of data in persistent storage from the 'Permissions' tab
4. Went into browser prefs and cleared all site data
5. Switched back to the YouTube tab


Actual results:

'Store Data in Persistent Storage' reverted to the default 'Use Default' state



Expected results:

The setting should've persisted
Component: Untriaged → Permission Manager
Product: Firefox → Core
This is currently done on purpose, which I can understand to a certain degree, but I can also see why it would be surprising.

We're working on simplifying/unifying the experience around both permissions and site data in preferences, so I could imagine we could want to separate the permission part to live in the "Permissions" section and make the site data dialog be purely about stored site data.

This is all speculation at this point and there are no actionable plans, so I'm leaning towards just WONTFIXing this bug as it's technically intended behavior. Your concern has been noted in any case.

Fischer, what do you think?
Component: Permission Manager → Preferences
Flags: needinfo?(fliu)
Product: Core → Firefox
I assume Firefox does not maintain a record of data permissions for websites without data in storage which is why the option resets upon clearing the data.  This to me sounds like a technical oversight and not intended behaviour.
(In reply to Johann Hofmann [:johannh] from comment #1)
> This is currently done on purpose, which I can understand to a certain
> degree, but I can also see why it would be surprising.
> 
> We're working on simplifying/unifying the experience around both permissions
> and site data in preferences, so I could imagine we could want to separate
> the permission part to live in the "Permissions" section and make the site
> data dialog be purely about stored site data.
> 
> This is all speculation at this point and there are no actionable plans, so
> I'm leaning towards just WONTFIXing this bug as it's technically intended
> behavior. Your concern has been noted in any case.
> 
> Fischer, what do you think?
I agreed. This is an area UX is still thinking and waiting for the user usage to analyse then come up with an new proposal.
The bug 1348223 is opened for this. I will duplicate this bug over there.

(In reply to erdbanfed from comment #2)
> I assume Firefox does not maintain a record of data permissions for websites
> without data in storage which is why the option resets upon clearing the
> data.  This to me sounds like a technical oversight and not intended
> behaviour.
This is still in the one of the next improvement target. Because this web api and feature is new, we would like to see some real usage results then make the next move. But still tracked in the bug 1348223.
Status: UNCONFIRMED → RESOLVED
Closed: 2 years ago
Flags: needinfo?(fliu)
Resolution: --- → DUPLICATE
Duplicate of bug: 1348223
You need to log in before you can comment on or make changes to this bug.