menus.onClicked listener error when invoked from sidebar/browser-action page

VERIFIED FIXED in Firefox 58

Status

P3
normal
VERIFIED FIXED
a year ago
6 months ago

People

(Reporter: slemmer.balazs, Assigned: zombie)

Tracking

57 Branch
mozilla58

Firefox Tracking Flags

(firefox57 wontfix, firefox58 verified)

Details

Attachments

(3 attachments)

(Reporter)

Description

a year ago
User Agent: Mozilla/5.0 (X11; Ubuntu; Linux x86_64; rv:56.0) Gecko/20100101 Firefox/56.0
Build ID: 20171003101214

Steps to reproduce:

Click on a context menu of an extension from a sidebar or browser-action page. The context menu and the listener is created according to the attachment.


Actual results:

The following error was logged to the extension debugging console:

TypeError: WeakMap key must be an object, got null  ext-browser.js:250:5


Expected results:

No error should have occured, and the listener function should have logged its arguments to the console.

Comment 1

a year ago
Might be something you know how to fix zombie?
status-firefox57: --- → wontfix
Flags: needinfo?(tomica)
Priority: -- → P3
(Assignee)

Comment 2

a year ago
Yeah, will investigate.
Assignee: nobody → tomica
Flags: needinfo?(tomica)
Comment hidden (mozreview-request)
(Assignee)

Updated

a year ago
Status: UNCONFIRMED → ASSIGNED
Ever confirmed: true

Comment 4

a year ago
mozreview-review
Comment on attachment 8924325 [details]
Bug 1409433 - Handle contextmenu clicks in non-tab content

https://reviewboard.mozilla.org/r/195562/#review200840
Attachment #8924325 - Flags: review?(aswan) → review+

Comment 5

a year ago
Pushed by tomica@gmail.com:
https://hg.mozilla.org/integration/autoland/rev/759c687e02d2
Handle contextmenu clicks in non-tab content r=aswan
https://hg.mozilla.org/mozilla-central/rev/759c687e02d2
Status: ASSIGNED → RESOLVED
Last Resolved: a year ago
status-firefox58: --- → fixed
Resolution: --- → FIXED
Target Milestone: --- → mozilla58

Comment 7

a year ago
Verified as fixed using Build identifier: Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:58.0) Gecko/20100101 Firefox/58.0. Please see console logs comparison between FF57 and FF58. 
Also, please note that if you test on Windows , extensions.webextensions.remote should be set to false since on Linux(where it was reported) this is false by default.
Status: RESOLVED → VERIFIED

Updated

a year ago
status-firefox58: fixed → verified

Updated

9 months ago
Product: Toolkit → WebExtensions

Updated

6 months ago
Duplicate of this bug: 1389387
You need to log in before you can comment on or make changes to this bug.