"./mach bootstrap" for updating Mercurial to 4.3.3 failed on Windows

RESOLVED DUPLICATE of bug 1405597

Status

()

Core
mach
RESOLVED DUPLICATE of bug 1405597
a month ago
a month ago

People

(Reporter: daoshengmu, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

a month ago
STP:

1. Run ./mach bootstrap from mozilla-build on Windows
2. Choose "2. Firefox for Desktop"

Expected result:
It should update Mercurial successfully or skip this update because Mercurial 4.2.2 is good to build code. Then, keeping updating other packages.


Actual Results:
It shows:

Collecting Mercurial
  Using cached mercurial-4.3.3.tar.gz
Installing collected packages: Mercurial
  Found existing installation: mercurial 4.2.2
    Uninstalling mercurial-4.2.2:
      Successfully uninstalled mercurial-4.2.2
  Running setup.py install for Mercurial ... error

---------------------------
building 'mercurial.cext.base85' extension
    error: Microsoft Visual C++ 9.0 is required. Get it from http://aka.ms/vcpython27

    ----------------------------------------
  Rolling back uninstall of mercurial
Command "c:\mozilla-build\python\python.exe -u -c "import setuptools, tokenize;__file__='c:\\users\\user\\appdata\\local\\temp\\pip-build-uqlpt5\\Mercurial\\setup.py';f=getattr(tokenize, 'open', open)(__file__);code=f.read().replace('\r\n', '\n');f.close();exec(compile(code, __file__, 'exec'))" install --record c:\users\user\appdata\local\temp\pip-vjiy0l-record\install-record.txt --single-version-externally-managed --compile" failed with error code 1 in c:\users\user\appdata\local\temp\pip-build-uqlpt5\Mercurial\
Error running mach:

    ['bootstrap']
Status: NEW → RESOLVED
Last Resolved: a month ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1405597
You need to log in before you can comment on or make changes to this bug.