Closed Bug 1409661 Opened 2 years ago Closed 2 years ago

[57] The Firefox firstrun page is set as a highlight when first opening the AS New Tab Page

Categories

(Firefox :: New Tab Page, defect)

57 Branch
defect
Not set

Tracking

()

VERIFIED FIXED
Firefox 58
Tracking Status
firefox57 --- wontfix
firefox58 --- verified
firefox59 --- verified

People

(Reporter: JuliaC, Assigned: andreio)

References

Details

[Note]:
- See https://github.com/mozilla/activity-stream/issues/3728
- Only the 57 beta builds are affected

[Affected versions]:
- 57.0b9 (20171016185129)

[Affected platforms]:
- Windows 10x64
- Ubuntu 16.04 x64
- macOS 10.12.1

[Steps to reproduce]:
1. Launch Firefox using a clean profile
2. Open a new tab and inspect the Highlights section

[Expected result]:
- The https://www.mozilla.org/en-US/firefox/57.0/firstrun/ is set as the first highlight (see the screencast https://goo.gl/Dr1y7N)

[Actual result]:
- The Highlight section is empty, as only the firstrun and privacy sites were opened (by default)

[Regression range]:
- It seems that this issue is reproducible starting with 57.0b1 (20170917031738) (the last 57.0a1 (2017-09-21) and the first 58.0a1 (2017-09-21) builds are not affected)

[Additional notes]:
- Neither the privacy page or the default bookmarks are not automatically added in the Highlights section at the first AS New Tab Page opening, so the firstrun page should respect this behavior, too.
We will discuss this with the designers, though this may be intended.  Setting to 'wontfix' for 57 at any rate
This is desired behavior because the user never had a chance to see the Highlight explainer and was shown a website they didn't themselves navigate to.
This is already the implemented behavior in Nightly.
Status: NEW → RESOLVED
Closed: 2 years ago
Resolution: --- → FIXED
I have to apologize because the Actual and Expected results are inverted by mistake in comment 0. So the right description was:

[Expected result]:
- The Highlight section is empty, as only the firstrun and privacy sites were opened (by default) 

[Actual result]:
- The https://www.mozilla.org/en-US/firefox/57.0/firstrun/ is set as the first highlight (see the screencast https://goo.gl/Dr1y7N)
Fixed by https://github.com/mozilla/activity-stream/pull/3695 uplifted via bug 1410541.
https://hg.mozilla.org/mozilla-central/rev/d1f0c44b2d79
Assignee: nobody → andrei.br92
Blocks: 1410541
Target Milestone: --- → Firefox 58
I managed to reproduce the bug using Firefox 57.0 - build 4 on Windows 10 x64.
I retested everything on latest Nightly 59 and beta 58.0b4 using Windows 10 x64, Ubuntu 16.04 x64 and Mac OS 10.11, but the bug is not reproducing anymore.
Status: RESOLVED → VERIFIED
Flags: qe-verify+
Component: Activity Streams: Newtab → New Tab Page
You need to log in before you can comment on or make changes to this bug.