Closed Bug 1409769 Opened 3 years ago Closed 3 years ago

idle-daily is still being triggered during mochitest runs

Categories

(Testing :: Mochitest, defect)

Version 3
defect
Not set
normal

Tracking

(firefox58 fixed)

RESOLVED FIXED
mozilla58
Tracking Status
firefox58 --- fixed

People

(Reporter: standard8, Assigned: standard8)

References

Details

Attachments

(1 file)

In bug 1402248 we tried to disable idle-daily during mochitest runs, by setting the pref to a recent time.

I've seen in a few test failures that idle-daily is still getting triggered and I've just been pointed to the run below, which indicates the same as well:

https://treeherder.mozilla.org/logviewer.html#?job_id=137833655&repo=try&lineNumber=3088

So, either the pref value is wrong, or it still didn't work for some reason...
I can reproduce the issue in comment 0 reliably with the patch from bug 1393800 and bug 1333126 applied on top of mozilla-central.
Blocks: 1393800
Testing this locally Gecko thinks roughly 22 years have elapsed since the last time we sent the idle-daily notification. I checked the values I get during startup here:

https://dxr.mozilla.org/mozilla-central/rev/20d57b9c4183973af4af5e078dff2aec0b74f928/widget/nsIdleService.cpp#179
So what's happening is that the we wait for the DAILY_SHORTENED_IDLE_SERVICE_SEC timeout (which is three minutes) and that happens smack in the middle of my tests.
We figured it - the pref is in seconds, not milliseconds (for some reason I'd assumed ms).
Assignee: nobody → standard8
Status: NEW → ASSIGNED
IIRC most of the prefs using timestamps use seconds, because of the integer limits, otherwise you should store strings.
Comment on attachment 8919806 [details]
Bug 1409769 - Properly disable idle-daily for mochitests, to avoid background interactions.

https://reviewboard.mozilla.org/r/190732/#review195942

oh, that is easy!
Attachment #8919806 - Flags: review?(jmaher) → review+
Pushed by mbanner@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/e713e2a6b0bd
Properly disable idle-daily for mochitests, to avoid background interactions. r=jmaher
https://hg.mozilla.org/mozilla-central/rev/e713e2a6b0bd
Status: ASSIGNED → RESOLVED
Closed: 3 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla58
You need to log in before you can comment on or make changes to this bug.