Closed Bug 140979 Opened 18 years ago Closed 18 years ago

Can't view source of a .eml file (message/rfc822)

Categories

(SeaMonkey :: General, defect)

x86
Linux
defect
Not set

Tracking

(Not tracked)

VERIFIED DUPLICATE of bug 77337

People

(Reporter: m, Assigned: Matti)

Details

Attachments

(1 file)

From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.0rc1) Gecko/20020417
BuildID:    2002041711

If a message/rfc822 file is viewed in the browser, it's not possible to view the
source of the message.

Reproducible: Always
Steps to Reproduce:
1. Open the attachment to this bug.
2. Right-click the page and choose "View Page Source".

Actual Results:  A download box appears, stating: "You have chosen to download a
file of type: "RFC-822 data" [message/rfc822; x-view-type=view-source] ...".

Expected Results:  The source of the message should be displayed, like it is
when you view a message's source in Mail, or when you view the source of any
other webpage.

Note: may be related to bug 11076; also note that mozilla doesn't even try to
display a .eml file as a mail message if the webserver doesn't report its
mimetype as message/rfc822 (i.e. you just get the plain text of that file, not
the formatted message).

May also be related to bug 83915.
Attached file Sample message
Try opening this attachment then viewing its source.
see bug 82369

*** This bug has been marked as a duplicate of 77337 ***
Status: UNCONFIRMED → RESOLVED
Closed: 18 years ago
Resolution: --- → DUPLICATE
vrfy dup
Status: RESOLVED → VERIFIED
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.