gamer.co.il: Hebrew text that comes after English text is displayed backwards

RESOLVED WORKSFORME

Status

()

RESOLVED WORKSFORME
17 years ago
10 years ago

People

(Reporter: sagiem, Assigned: mkaply)

Tracking

Trunk
x86
Windows 2000
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

Attachments

(3 attachments)

(Reporter)

Description

17 years ago
It appears that in some of the texts (not all of them), the hebrew text is
displayed backwards when it comes after some English text.
In the above URL, all Hebrew text looks fine except for the secondary headlines
(bold and white above the big green lines).

Comment 1

17 years ago
looks fine here: Mac OSX with build 2002051008. See screen shot.
Sagie, are you still getting this bug with up to date builds?

Comment 2

17 years ago
Created attachment 83260 [details]
The site on correcnt osx build
(Reporter)

Comment 3

17 years ago
Created attachment 83264 [details]
Bug exists on 2002051006

Comment 4

16 years ago
WFM
Win98SE 2002060208
Tried it at various screen resolutions and text zooms. All absolutely fine.

-Jonny
(Reporter)

Comment 5

16 years ago
Indeed, seems fine on 2002060208/win2k.
(Reporter)

Comment 6

16 years ago
Woops, just got back to the tab with the page amd it's all wrong again, just
like in my screenshot.

Comment 7

16 years ago
Sagie, are you able to access this site? the URL you gave is giving me a server
error, and chopping of it's end gives me a 404 from a nonstop (the company) server.
Summary: Hebrew text that comes after English text is displayed backwards → gamer.co.il: Hebrew text that comes after English text is displayed backwards
(Reporter)

Comment 8

16 years ago
The guys at gamer.co.il are moving to another servers farm and the site is
closed for the weekend, as you can see in www.gamer.co.il

Comment 9

16 years ago
Created attachment 109727 [details]
shows web page with backwards text circled in red
I don't think the problem in attachment 109727 [details] is the same as in this bug. There
is already evangelism bug 122322 about www.a7.org and the mix of logical and
visual Hebrew which they serve to Mozilla-based browsers.

Comment 11

16 years ago
Confirmed.
UA: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.3b) Gecko/20030108

Under Win2k, the site looks the same as Attachment 109727 [details].
It works fine with Mozilla 1.01 (20020830) under Linux RedHat 8.0.

Prog.

Comment 12

15 years ago
The bug is still there with 1.4b/20030526, but when I open the page in Composer,
the page looks perfectly fine. Odd.

Prog.

Comment 13

15 years ago
Does anyone still see this bug? (I can't test here, as it never was broken on
osx, and is still ok here)
(Reporter)

Comment 14

15 years ago
Confirming with Firebird 0.6 (Gecko/20030516).

Comment 15

15 years ago
per Comment #14 
Status: UNCONFIRMED → NEW
Ever confirmed: true

Updated

14 years ago
Blocks: 248447

Comment 16

14 years ago
The site was redesigned, and its layout no longer has this problem. See updated
URL of the same news item. 

If anyone still has the source of the old page, please validate it and open a
new layout bug (if it's valid but isn't properly rendered in Gecko).

Prog.
Status: NEW → RESOLVED
Last Resolved: 14 years ago
Resolution: --- → FIXED

Comment 17

14 years ago
Site redesign has nothing to do with Mozilla code.  Since this bug has not been
marked as Tech Evangelism, and no code was checked in to correct anything, FIXED
is the wrong resolution.

-> WORKSFORME.  (Although it might be more appropriate to change the Product,
I'll leave that to somebody else if they wish.)
Status: RESOLVED → REOPENED
Resolution: FIXED → ---

Updated

14 years ago
Status: REOPENED → RESOLVED
Last Resolved: 14 years ago14 years ago
Resolution: --- → WORKSFORME
I just saw exactly the same problem in a current trunk build on
http://www.ynet.co.il/articles/0,7340,L-3021229,00.html. I've saved the HTML,
and I'll try to create a minimal testcase.
Status: RESOLVED → REOPENED
Resolution: WORKSFORME → ---
On second thoughts it makes more sense to attach the minimized testcase to bug
248447 and leave this as WORKSFORME. Sorry for the bugspam.
Status: REOPENED → RESOLVED
Last Resolved: 14 years ago14 years ago
Resolution: --- → WORKSFORME

Updated

10 years ago
Component: Layout: BiDi Hebrew & Arabic → Layout: Text
QA Contact: zach → layout.fonts-and-text
You need to log in before you can comment on or make changes to this bug.