Closed Bug 1410048 Opened 2 years ago Closed 3 months ago

"Copy object" does not work for long strings

Categories

(DevTools :: Console, defect, P3)

defect

Tracking

(firefox57 affected, firefox58 affected)

RESOLVED DUPLICATE of bug 1424721
Tracking Status
firefox57 --- affected
firefox58 --- affected

People

(Reporter: nchevobbe, Unassigned)

Details

Steps to reproduce:
1. Open the console
2. Evaluate `"foo ".repeat(10000)`
3. This will create a longString (string with more than 10,000 chars), which has an actor associated to retrieve the whole string
4. Right-click on the result, and choose "Copy object"


Expected results:
The whole string is copied into the clipboard

Actual results:
Nothing is copied in the clipboard, and a warning message is displayed in browser console: 
```
"onPacket threw an exception: Error: Server did not specify an actor, dropping packet: {"error":"unknownError","message":"error occurred while processing 'evaluateJSAsync: TypeError: objActor.obj is undefined\nStack: evalWithDebugger@resource://devtools/shared/base-loader.js -> resource://devtools/server/actors/webconsole.js:1323:13\nonEvaluateJS@resource://devtools/shared/base-loader.js -> resource://devtools/server/actors/webconsole.js:917:20\nonEvaluateJSAsync@resource://devtools/shared/base-loader.js -> resource://devtools/server/actors/webconsole.js:888:20\nonPacket@resource://devtools/shared/base-loader.js -> resource://devtools/server/main.js:1791:15\nreceiveMessage@resource://devtools/shared/base-loader.js -> resource://devtools/shared/transport/transport.js:761:7\nLine: 1323, column: 13"}
Stack: onPacket@resource://devtools/shared/base-loader.js -> resource://devtools/shared/client/debugger-client.js:787:9
send/<@resource://devtools/shared/base-loader.js -> resource://devtools/shared/transport/transport.js:570:13
exports.makeInfallible/<@resource://devtools/shared/base-loader.js -> resource://devtools/shared/ThreadSafeDevToolsUtils.js:109:14
exports.makeInfallible/<@resource://devtools/shared/base-loader.js -> resource://devtools/shared/ThreadSafeDevToolsUtils.js:109:14
Line: 787, column: 9"
```

"Store as global variable" does not work either

---

This might be because we don't add the actor reference as an attribute in Reps. To be confirmed
Marking 57 as affected since "store as global variable" does not work there (but copy object feature was introduced in 58)
Priority: -- → P3
Whiteboard: [console-html]
Whiteboard: [console-html] → [reserve-console-html]
Whiteboard: [reserve-console-html]
Product: Firefox → DevTools

Looks like it was fixed in Bug 1424721

Status: NEW → RESOLVED
Closed: 3 months ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1424721
You need to log in before you can comment on or make changes to this bug.