Closed Bug 1410072 Opened 2 years ago Closed 2 years ago

Permaorange test-verify browser/base/content/test/performance/browser_startup.js | Uncaught exception - [Exception... "Component returned failure code: 0x804b000a (NS_ERROR_MALFORMED_URI) [xpcIJSModuleLoader.getComponentLoadStack]"

Categories

(Firefox :: General, defect, P5)

defect

Tracking

()

RESOLVED FIXED
Firefox 59
Tracking Status
firefox59 --- fixed

People

(Reporter: intermittent-bug-filer, Assigned: florian)

References

Details

(Keywords: intermittent-failure)

Attachments

(1 file)

Filed by: nbeleuzu [at] mozilla.com

https://treeherder.mozilla.org/logviewer.html#?job_id=138210273&repo=autoland

https://queue.taskcluster.net/v1/task/KHarTODhQMSffzvRKuD-cg/runs/0/artifacts/public/logs/live_backing.log

Intermittent browser/base/content/test/performance/browser_startup.js | Uncaught exception - [Exception... "Component returned failure code: 0x804b000a (NS_ERROR_MALFORMED_URI) [xpcIJSModuleLoader.getComponentLoadStack]"  nsresult: "0x804b000a (NS_ERROR_MALFORMED_URI)"  location: "JS frame :: chrome://mochitests/content/browser/browser/base/content/test/performance/browser_startup.js :: data[phase].components< :: line 163"  data: no]
Summary: Intermittent browser/base/content/test/performance/browser_startup.js | Uncaught exception - [Exception... "Component returned failure code: 0x804b000a (NS_ERROR_MALFORMED_URI) [xpcIJSModuleLoader.getComponentLoadStack]" nsresult: "0x804b000a (NS_ERROR → Permaorange test-verify-OSX browser/base/content/test/performance/browser_startup.js | Uncaught exception - [Exception... "Component returned failure code: 0x804b000a (NS_ERROR_MALFORMED_URI) [xpcIJSModuleLoader.getComponentLoadStack]"
These failures were first seen with the test-verify run triggered by bug 1347532, but I do not know if it was a pre-existing problem. browser_startup.js has several other open bugs, but none that look like this.
See Also: → 1406204
https://wiki.mozilla.org/Bugmasters#Intermittent_Test_Failure_Cleanup
Status: NEW → RESOLVED
Closed: 2 years ago
Resolution: --- → INCOMPLETE
This is trivially-reproducible on Try across all platforms still. Florian, is this something you'd be interested in looking at?
Status: RESOLVED → REOPENED
Flags: needinfo?(florian)
Resolution: INCOMPLETE → ---
Summary: Permaorange test-verify-OSX browser/base/content/test/performance/browser_startup.js | Uncaught exception - [Exception... "Component returned failure code: 0x804b000a (NS_ERROR_MALFORMED_URI) [xpcIJSModuleLoader.getComponentLoadStack]" → Permaorange test-verify browser/base/content/test/performance/browser_startup.js | Uncaught exception - [Exception... "Component returned failure code: 0x804b000a (NS_ERROR_MALFORMED_URI) [xpcIJSModuleLoader.getComponentLoadStack]"
(In reply to Ryan VanderMeulen [:RyanVM] from comment #5)
> This is trivially-reproducible on Try across all platforms still. Florian,
> is this something you'd be interested in looking at?

Do you have a link to a try build where this failed?
I wonder if https://searchfox.org/mozilla-central/rev/e6fd22c37447579bd544254685c80fd0da221d93/js/xpconnect/loader/mozJSComponentLoader.cpp#1061 needs a change for devedition too. But that would give NS_ERROR_NOT_IMPLEMENTED, not NS_ERROR_MALFORMED_URI. I guess I'll need to push this to try with more debug logging to figure out what's actually going on.

https://hg.mozilla.org/try/rev/4fe83f30ea86#l1.12 in your try push (which doesn't match the patch we actually landed in bug 1426793 seems responsible for the "This test contains no passes, no fails and no todos." errors you are getting on some platforms.
Yes, the NS_ERROR_NOT_IMPLEMENTED condition was what I hit when I amended browser_startup.js to include DevEdition in that check as well. Rather than debug the component loader code, I decided to take the easy way out and skip the test on DevEdition instead (which in effect was no worse than what we were doing before, except we're skipping it at the manifest level instead of via an early return).

Anyway, that's orthogonal to this bug :). This bug is what I hit on everything that wasn't DevEdition in the TV job, and those other platforms/flavors wouldn't have been affected by the DevEdition-only changes I was making.
(In reply to Florian Quèze [:florian] from comment #8)
> I guess
> I'll need to push this to try with more debug logging to figure out what's
> actually going on.

Actually, after sleeping on it the cause of the malformed URIs is obvious:
https://searchfox.org/mozilla-central/rev/e6fd22c37447579bd544254685c80fd0da221d93/browser/base/content/test/performance/browser_startup.js#160 modifies the stored data, so next run can't access the full URIs anymore.

So this issue really affects only test-verify.
Attached patch PatchSplinter Review
To pass test-verify, the startup tests should never modify the startupRecorder data. I used Cu.cloneInto because it helped performance a lot for the startup flicker test, by removing all cross compartment wrappers.

browser_startup_images.js currently doesn't really need it, but I figured it's safer to do it everywhere, so that if someone copy/pastes the startup test skeleton in the future to add a new test, they don't reproduce the mistake I made in browser_startup.js

Try seems happy: https://treeherder.mozilla.org/#/jobs?repo=try&revision=4bb03db3ebea2b8419b43ae86a6175b6d15c66fd
The TV failures on this try push are from other changesets that landed on inbound recently but hadn't been pushed to try yet.
Assignee: nobody → florian
Flags: needinfo?(florian)
Attachment #8939885 - Flags: review?(jhofmann)
Comment on attachment 8939885 [details] [diff] [review]
Patch

Review of attachment 8939885 [details] [diff] [review]:
-----------------------------------------------------------------

Thanks!
Attachment #8939885 - Flags: review?(jhofmann) → review+
Pushed by florian@queze.net:
https://hg.mozilla.org/integration/mozilla-inbound/rev/eaf8243e6e33
browser/base/content/test/performance tests should not modify startupRecorder data in order to pass test-verify, r=johannh.
https://hg.mozilla.org/mozilla-central/rev/eaf8243e6e33
Status: REOPENED → RESOLVED
Closed: 2 years ago2 years ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 59
You need to log in before you can comment on or make changes to this bug.