Closed Bug 1410218 Opened 2 years ago Closed Last year

Crash in java.lang.NullPointerException: Attempt to invoke virtual method ''int com.google.android.gms.cast.MediaStatus.getPlayerState()'' on a null object reference at org.mozilla.gecko.ChromeCastPlayer$VideoPlayCallback.onStatusUpdated(ChromeCastPlay...

Categories

(Firefox for Android :: Screencasting, defect, P1, critical)

Firefox 52
Unspecified
Android
defect

Tracking

()

VERIFIED FIXED
Firefox 63
Tracking Status
firefox56 --- wontfix
firefox57 --- wontfix
firefox61 --- wontfix
firefox62 --- verified
firefox63 --- verified

People

(Reporter: philipp, Assigned: petru)

References

Details

(Keywords: crash, topcrash, Whiteboard: --do_not_change--[priority:high])

Crash Data

Attachments

(1 file)

This bug was filed from the Socorro interface and is 
report bp-fb4c4b86-9168-4c85-aef9-43b920171019.
=============================================================
java.lang.NullPointerException: Attempt to invoke virtual method 'int com.google.android.gms.cast.MediaStatus.getPlayerState()' on a null object reference
	at org.mozilla.gecko.ChromeCastPlayer$VideoPlayCallback.onStatusUpdated(ChromeCastPlayer.java:89)
	at com.google.android.gms.cast.RemoteMediaPlayer.onStatusUpdated(Unknown Source:6)
	at com.google.android.gms.cast.RemoteMediaPlayer.zza(Unknown Source:0)
	at com.google.android.gms.cast.RemoteMediaPlayer$1.onStatusUpdated(Unknown Source:2)
	at com.google.android.gms.cast.internal.zzm.zzcf(Unknown Source:69)
	at com.google.android.gms.cast.RemoteMediaPlayer.onMessageReceived(Unknown Source:2)
	at com.google.android.gms.cast.internal.zze$zzb$4.run(Unknown Source:34)
	at android.os.Handler.handleCallback(Handler.java:789)
	at android.os.Handler.dispatchMessage(Handler.java:98)
	at android.os.Looper.loop(Looper.java:164)
	at android.app.ActivityThread.main(ActivityThread.java:6541)
	at java.lang.reflect.Method.invoke(Native Method)
	at com.android.internal.os.Zygote$MethodAndArgsCaller.run(Zygote.java:240)
	at com.android.internal.os.ZygoteInit.main(ZygoteInit.java:767)

the crash signature is regressing on fennec since version 52 - looking related to bug 1305351...
Please help advise. Thanks!
Component: Screencasting → Audio/Video
Flags: needinfo?(bwu)
This looks like a screencast bug, not a real audio/video bug. 
Change back to Screencasting. :-)
Component: Audio/Video → Screencasting
Flags: needinfo?(bwu)
Crash Signature: org.mozilla.gecko.ChromeCastPlayer$VideoPlayCallback.onStatusUpdated(ChromeCastPlayer.java)] → org.mozilla.gecko.ChromeCastPlayer$VideoPlayCallback.onStatusUpdated(ChromeCastPlayer.java)] [@ java.lang.NullPointerException: Attempt to invoke virtual method 'int com.google.android.gms.cast.MediaStatus.getPlayerState()' on a null object reference at…
[triage] Top crasher #29 – P1 for now and will re-eval against other top crashers.
Flags: needinfo?(sdaswani)
Priority: -- → P1
(In reply to Michael Comella (:mcomella) [needinfo or I won't see it] from comment #3)
> [triage] Top crasher #29 – P1 for now and will re-eval against other top
> crashers.

Agree.
Flags: needinfo?(sdaswani)
This is currently the #4 topcrash on Beta61.
Flags: needinfo?(sdaswani)
Flags: needinfo?(sdaswani)
Whiteboard: --do_not_change--[priority:high]
Assignee: nobody → petru.lingurar
Status: NEW → ASSIGNED
Attachment #8997375 - Flags: review?(sdaswani) → review?(nchen)
Comment on attachment 8997375 [details]
Bug 1410218 - Fix NPE when cast fails;

https://reviewboard.mozilla.org/r/261164/#review268304
Attachment #8997375 - Flags: review?(nchen) → review+
Keywords: checkin-needed
https://hg.mozilla.org/mozilla-central/rev/ac280d2e0cbe
Status: ASSIGNED → RESOLVED
Closed: Last year
Resolution: --- → FIXED
Target Milestone: --- → Firefox 63
This looks like a high volume crash on release. Petru, do you want to request uplift to beta?
Flags: needinfo?(petru.lingurar)
Keywords: topcrash
Comment on attachment 8997375 [details]
Bug 1410218 - Fix NPE when cast fails;

Approval Request Comment
[Feature/Bug causing the regression]: Casting videos
[User impact if declined]: Crash if failing to load the video
[Is this code covered by automated tests?]: No
[Has the fix been verified in Nightly?]: No
[Needs manual test from QE? If yes, steps to reproduce]: 
Trying to cast any videos from ok.ru, like https://ok.ru/live/914459205195 will crash the app. Issue exists in regards to other video platforms as well.
[List of other uplifts needed for the feature/fix]: --
[Is the change risky?]: No
[Why is the change risky/not risky?]: Small change only applying when the app is not in the expected state.
[String changes made/needed]: --
Flags: needinfo?(petru.lingurar)
Attachment #8997375 - Flags: approval-mozilla-beta?
Flags: qe-verify+
Verified as fixed in Nightly 63 on Google Pixel XL with Chromecast 2. The cast icon still appears for the video (https://ok.ru/live/914459205195) but it won't actually cast the video. The cast icon does not appear for any Youtube video.
Flags: qe-verify+
I don't think you need to remove the qe-verify+ flag here (because, if the status changed to verified, it should not show up on your queries any longer)
Status: RESOLVED → VERIFIED
Comment on attachment 8997375 [details]
Bug 1410218 - Fix NPE when cast fails;

Fix for an android top crash, let's uplift for beta (will land for beta 18)
Attachment #8997375 - Flags: approval-mozilla-beta? → approval-mozilla-beta+
Verified as fixed in 62 Beta 17 on Sony Xperia Z5 (Android 7.0), Samsung S8+ (Android 8.0.0) & Google Pixel XL (Android P). The cast only worked on Sony Xperia Z5 but otherwise the issues did not reproduce on any of the devices above mentioned.
You need to log in before you can comment on or make changes to this bug.