Closed Bug 1410225 Opened 5 years ago Closed 5 years ago

Crash [@ mozilla::MediaFormatReader::RequestVideoData ]

Categories

(Core :: Audio/Video: Playback, defect, P2)

defect

Tracking

()

RESOLVED FIXED
mozilla58
Tracking Status
firefox58 --- fixed

People

(Reporter: florian, Assigned: jwwang)

References

()

Details

Attachments

(1 file)

Flags: needinfo?(alwu)
It looks like the problem is in seekToNextFrame().
Flags: needinfo?(alwu)
Assignee: nobody → jwwang
Component: Audio/Video → Audio/Video: Playback
bughunter reproduced this on https://codepen.io/anon/pen/QqYXPX  as well as 

Assertion failure: mSeekPromise.IsEmpty() (No sample requests allowed while seeking), at /builds/worker/workspace/build/src/dom/media/MediaFormatReader.cpp:1598
#01: mozilla::detail::ProxyRunnable<mozilla::MozPromise<RefPtr<mozilla::VideoData>, mozilla::MediaResult, true>, RefPtr<mozilla::MozPromise<RefPtr<mozilla::VideoData>, mozilla::MediaResult, true> > (mozilla::MediaFormatReader::*)(const mozilla::media::TimeUnit&), mozilla::MediaFormatReader, StoreCopyPassByRRef<mozilla::media::TimeUnit> >::Run [xpcom/base/nsAutoPtr.h:38]
#02: mozilla::AutoTaskDispatcher::TaskGroupRunnable::Run [xpcom/threads/TaskDispatcher.h:212]
#03: mozilla::TaskQueue::Runner::Run [xpcom/threads/TaskQueue.cpp:245]
#04: nsThreadPool::Run [xpcom/threads/nsThreadPool.cpp:179]
#05: nsThread::ProcessNextEvent [mfbt/Maybe.h:445]
#06: NS_ProcessNextEvent [xpcom/threads/nsThreadUtils.cpp:512]
#07: mozilla::ipc::MessagePumpForNonMainThreads::Run [ipc/glue/MessagePump.cpp:335]
#08: MessageLoop::RunInternal [ipc/chromium/src/base/message_loop.cc:327]
#09: MessageLoop::Run [ipc/chromium/src/base/message_loop.cc:298]
#10: nsThread::ThreadFunc [xpcom/threads/nsThread.cpp:427]
Attachment #8920510 - Flags: review?(gsquelart)
Comment on attachment 8920510 [details]
Bug 1410225 - return the pending seek promise for SeekToNextFrame() when a seek is already in action.

https://reviewboard.mozilla.org/r/191512/#review197066

::: commit-message-611ac:6
(Diff revision 1)
> +Bug 1410225 - return the pending seek promise for SeekToNextFrame() when a seek is already in action.
> +
> +MDSM doesn't reset the decoding pipeline of MFR when doing NextFrameSeek and
> +therefore fails the assertion by requesting video data while MFR is still seeking.
> +
> +We put the fix in the media elemnt because it doesn't make sense to do

'elemnt' -> 'element'
Attachment #8920510 - Flags: review?(gsquelart) → review+
Thanks!
Pushed by jwwang@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/34f4fb060a2b
return the pending seek promise for SeekToNextFrame() when a seek is already in action. r=gerald
https://hg.mozilla.org/mozilla-central/rev/34f4fb060a2b
Status: NEW → RESOLVED
Closed: 5 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla58
You need to log in before you can comment on or make changes to this bug.