mozilla-central out of date

RESOLVED FIXED

Status

Webtools
DXR
RESOLVED FIXED
a month ago
12 days ago

People

(Reporter: fubar, Unassigned)

Tracking

Trunk

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

a month ago
something changed and we're no longer using the right version of rust in the indexing docker images:

checking for rustc... /usr/local/bin/rustc
checking for cargo... /usr/local/bin/cargo
checking rustc version... 1.19.0
checking cargo version... 0.20.0
ERROR: Rust compiler 1.19.0 is too old.

To compile Rust language sources please install at least
version 1.20.0 of the 'rustc' toolchain and make sure it is
first in your path.

You can verify this by typing 'rustc --version'.

If you have the 'rustup' tool installed you can upgrade
to the latest release by typing 'rustup update'. The
installer is available from https://rustup.rs/
(Reporter)

Comment 1

a month ago
I must be getting slow in my old age; just need to respin the indexing docker image. doing that now.
Rebuilding the docker image would probably bring it up to date, since it calls rustup.
Heh, midair collision!
(Reporter)

Comment 4

12 days ago
belatedly, fixed
Status: NEW → RESOLVED
Last Resolved: 12 days ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.