Closed Bug 1410239 Opened 5 years ago Closed 5 years ago

Remove skip-if and random-if WR reftest annotations

Categories

(Core :: Graphics: WebRender, enhancement, P1)

Other Branch
enhancement

Tracking

()

RESOLVED FIXED
mozilla58
Tracking Status
firefox58 --- fixed

People

(Reporter: kats, Assigned: kats)

Details

(Whiteboard: [wr-mvp] [gfx-noted])

Attachments

(2 files)

We have some reftests that I marked random-if or skip-if during the switch to layers free. More things have been fixed since then and these reftests are mostly good now. At least they're not behaving randomly.
Here I just removed the annotations to see what happens:
https://treeherder.mozilla.org/#/jobs?repo=try&revision=50a014d8fef00cb518b7486e01e8683922449be8

Looks like one is permafailing and one is still failing to load, probably because we didn't implement the mozPrintCallback thing for canvases.

Here's my attempted fix:
https://treeherder.mozilla.org/#/jobs?repo=try&revision=1d0d4aa78d4851a78a667c60b26e690734035b5c
Status: NEW → ASSIGNED
Priority: P3 → P1
Whiteboard: [gfx-noted][wr-mvp][triage] → [wr-mvp] [gfx-noted]
Comment on attachment 8920440 [details]
Bug 1410239 - Remove some random-if(webrender) annotations.

https://reviewboard.mozilla.org/r/191410/#review196606
Attachment #8920440 - Flags: review?(jmuizelaar) → review+
Comment on attachment 8920441 [details]
Bug 1410239 - Ensure the mozPrintCallback gets invoked when painting canvases.

https://reviewboard.mozilla.org/r/191412/#review196608
Attachment #8920441 - Flags: review?(jmuizelaar) → review+
From the try push I did at https://treeherder.mozilla.org/#/jobs?repo=try&revision=cb09d10f74f3b4523d0abd37e0ba32bdc8d46aeb it looks like anim-pattern-attr-presence-01.svg is actually basically passing, but has a variable fuzziness. Highest fuzzy needed so far is (1,350). I'll change that one from fails-if to fuzzy-if.
Just to be extra safe I retriggered the reftests a bunch on this try push:
https://treeherder.mozilla.org/#/jobs?repo=try&revision=779d7b8ff894807106299dd036d1d106730d3ea4

Looks like ogg-video/444-1-ref.html is still sometimes rendering the video at the wrong scale. no idea why. But I'll leave that one as random-if.
Pushed by kgupta@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/feca3ac01227
Remove some random-if(webrender) annotations. r=jrmuizel
https://hg.mozilla.org/integration/autoland/rev/573274df0d0e
Ensure the mozPrintCallback gets invoked when painting canvases. r=jrmuizel
https://hg.mozilla.org/mozilla-central/rev/feca3ac01227
https://hg.mozilla.org/mozilla-central/rev/573274df0d0e
Status: ASSIGNED → RESOLVED
Closed: 5 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla58
You need to log in before you can comment on or make changes to this bug.