Closed Bug 1410279 Opened 3 years ago Closed 3 years ago

"e10s (pid)" no longer show on tab's tooltip in Nightly

Categories

(Firefox :: Tabbed Browser, defect, P1)

defect

Tracking

()

RESOLVED FIXED
Firefox 58
Tracking Status
firefox-esr52 --- unaffected
firefox56 --- unaffected
firefox57 --- unaffected
firefox58 --- fixed

People

(Reporter: yfdyh000, Assigned: Felipe)

References

Details

(Keywords: nightly-community, regression)

i.e. Bug 1333277 - [multi-e10s] add pid of a tab to tooltip


Regression range:
https://hg.mozilla.org/integration/mozilla-inbound/pushloghtml?fromchange=84b2d5c67f73b48b760ef3f12aed9e8796441635&tochange=1485df2619bce4f7f424d1f1ff6b883ed7f23b26

1485df2619bc	Dragana Damjanovic — Bug 1408019 - Code clean up for sSupportedRelValues. r=bz
I arrived here after going through mozregression and finding the same thing as Yang above. The hover PIDs are very useful for quickly identifying to which process to attach a debugger.
Duplicate of this bug: 1410066
Assignee: nobody → felipc
Blocks: 1407351
Priority: -- → P1
yeah, we need the process ids back. That information is super useful for debugging (also in opt builds when doing performance work).
Pushed by felipc@gmail.com:
https://hg.mozilla.org/integration/mozilla-inbound/rev/b721be9535ab
Fix bad merge of bug 1407351, restoring the process id indicator on tabs (nightly only). r=me
(In reply to Olli Pettay [:smaug] (work week Oct 16-20) from comment #4)
> yeah, we need the process ids back. That information is super useful for
> debugging (also in opt builds when doing performance work).

Sorry, it was not intentional that it got removed, just a bad merge.

Note: there's a small change in that the tab won't say "e10s" anymore. It will just be
"tab title (pid: NNNN)" for remote tabs.
https://hg.mozilla.org/mozilla-central/rev/b721be9535ab
Status: NEW → RESOLVED
Closed: 3 years ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 58
You need to log in before you can comment on or make changes to this bug.