umschau.com - bad Javascript

RESOLVED WORKSFORME

Status

Tech Evangelism Graveyard
German
RESOLVED WORKSFORME
17 years ago
3 years ago

People

(Reporter: tessarakt, Unassigned)

Tracking

Details

(Whiteboard: [eurocontest], URL)

(Reporter)

Description

17 years ago
Steps to reproduce:

1. Go to http://www.umschau.com
2. Enter "Theater" in the text box below "suchen" on the left and click on "finden".
3. It says: "Es wurden 25 Artikel zum Suchbegriff Theater gefunden. Zum Lesen
klicken Sie bitte auf die Schlagzeile." ("25 articels found for "Theater". For
reading, click on the headline")
4. Hover over and click on the headlines.

Expected results:

The article should be opened.

Actual results:

Noting happens.


Reason: unknown

Comment 1

17 years ago
Confirmed
2002042803/WinXP
Status: UNCONFIRMED → NEW
Ever confirmed: true
OS: Linux → All
Summary: [umschau.com] bad Javascript → umschau.com - bad Javascript
Whiteboard: [eurocontest]

Comment 2

16 years ago
WFM 2002060208 Win2k

Updated

16 years ago
Severity: major → critical
Priority: -- → P2

Comment 3

16 years ago
no idea why it seemed to work, guess i confused the browser windows.
testcase:
<table><tr><a href="test"><td>test</td><td></td></a></tr></table>
this is what the site does, it spans an ahref over multiple tds. doesnt work in
ns 4.79 and mozilla. no valid html.
also wrong is the dtd <!DOCTYPE HTML PUBLIC "-//IETF//DTD HTML//EN"> this is
html2 and doesnt allow tables eg.
informed site owner of these things
Status: NEW → ASSIGNED

Comment 4

16 years ago
Steps to reproduce:

1.  Go to http://seattletimes.nwsource.com/html/home/
2.  Enlarge the photo by clicking "Enlarge" (using another browser)
3.  After the enlarged photo opens in a small window, try clicking close using
Mozilla 1.2.1.

Expected result:

The small window should close.

Actual result:
 
In Mozilla 1.2.1 nothing happens.Javascript does not work.

Reason: unknown
New Component
Component: Europe: West → German

Comment 6

15 years ago
default german owner
Assignee: nitot → german
Status: ASSIGNED → NEW
QA Contact: z-caillon-obsolete2 → german
(Reporter)

Comment 7

12 years ago
Just tried it again. The site says "Zum Lesen klicken Sie bitte auf die Schlagzeile.", but still nothing happens.
(Reporter)

Comment 8

10 years ago
@KCastleman: Please open a separate bug for your problem!

Btw: Does not work in Konqueror either. Has anyone tested with IE?
(Reporter)

Comment 9

10 years ago
Yes, works in a recent Internet Explorer ...
resolving since the site changed its layout according to http://web.archive.org/web/*/http://www.umschau.com/
feel free to reopen if you disagree and can tell why.
Status: NEW → RESOLVED
Last Resolved: 9 years ago
Resolution: --- → INVALID

Comment 11

9 years ago
FIXED, since the point of a TE bug is to get the site to change.
Resolution: INVALID → FIXED
(Reporter)

Comment 12

9 years ago
(In reply to comment #10)
> resolving since the site changed its layout according to
> http://web.archive.org/web/*/http://www.umschau.com/
> feel free to reopen if you disagree and can tell why.

No, the site did not change it's layout. umschau.com ist now a start page for multiple free papers, but http://www.umschau.de/umschau/ seems to be exactly the page that was on http://www.umschau.com/ before.

However, I cannot confirm the wrong behavior at the moment, because they seem to have other, additional problems: 

"Active Server Pages error 'ASP 0126'

Include file not found

/umschau/suchen.asp, line 2

The include file 'Connections/BA47_Artikel.asp' was not found."
Status: RESOLVED → REOPENED
Resolution: FIXED → ---
(Reporter)

Comment 13

8 years ago
Search works, bug appears as before.

Comment 14

8 years ago
w3 validator says:
Result: 1141 Errors, 4 warning(s) 
what they do is:
<a href="arc_zeigen.asp?id=252" onMouseOut="MM_swapImgRestore()" OnMouseOver="MM_swapImage('0','','images/pf_r.gif',1)"> 
<td><img src="images/dummy.gif" width="7" height="13" name="0" border="0"></td>
<td valign="top" align="left" width="80">23.09.00</td>
<td valign="top" align="left" width="260">Henstedt-Ulzburg</td>
<td valign="top" align="left" width="935">Jugendschutzbeauftragte lädt ein:
"Komm mit - Hau ab"</td>
</a> 

so this breaks down to
<table>
<tr>
<a href="f00">
<td>a</td>
<td>b</td>
</a>
</tr>
</table>
which is plain invalid html and we dont recognize an href at all.

Updated

5 years ago
Severity: critical → normal
Priority: P2 → --
This seems fixed to me. 

Going to http://www.umschau.de/umschau/ and entering "Theater" into the search box, then clicking on a result opens a page.
Status: REOPENED → RESOLVED
Last Resolved: 9 years ago4 years ago
Resolution: --- → WORKSFORME
Product: Tech Evangelism → Tech Evangelism Graveyard
You need to log in before you can comment on or make changes to this bug.