Closed Bug 1410376 Opened 2 years ago Closed 2 years ago

7.22 - 8.69% remote-nytimes (android-4-4-armv7-api16, android-7-1-armv8-api16) regression on push 38758d31bd62eb0a1d8c1374aaaa61787018d4da (Wed Oct 18 2017)

Categories

(Firefox :: General, defect)

54 Branch
Unspecified
Android
defect
Not set

Tracking

()

RESOLVED FIXED
Firefox 58
Tracking Status
firefox-esr52 --- unaffected
firefox56 --- unaffected
firefox57 --- unaffected
firefox58 --- fixed

People

(Reporter: igoldan, Assigned: mrbkap)

References

Details

(Keywords: regression)

Attachments

(1 file)

We have detected an autophone (Android) regression from push:

https://hg.mozilla.org/integration/autoland/pushloghtml?changeset=38758d31bd62eb0a1d8c1374aaaa61787018d4da

As author of one of the patches included in that push, we need your help to address this regression.

Regressions:

  9%  remote-nytimes summary android-7-1-armv8-api16 opt      1,145.04 -> 1,244.57
  7%  remote-nytimes summary android-4-4-armv7-api16 opt      1,890.92 -> 2,027.49


You can find links to graphs and comparison views for each of the above tests at: https://treeherder.mozilla.org/perf.html#/alerts?id=10077

On the page above you can see an alert for each affected platform as well as a link to a graph showing the history of scores for this test. There is also a link to a treeherder page showing the jobs in a pushlog format.

To learn more about the regressing test(s), please see: https://wiki.mozilla.org/EngineeringProductivity/Autophone
:mrbkap It looks like some of the changes from bug 1406212 caused these Android regressions. Can you please look over this issue?
Flags: needinfo?(mrbkap)
Blocks: 1402299
Assignee: nobody → mrbkap
Flags: needinfo?(mrbkap)
I'd prefer if we revert the GetBoolPref(.., true) to GetBoolPref(.., false).. That way, we don't need to have that pref defined anywhere else. And I _believe_ all the other test harness changes will still be correct.

If that's not the case, and this suggestion would require further changes somewhere else, let me know
Attachment #8920705 - Flags: review?(felipc)
Comment on attachment 8920705 [details]
Bug 1410376 - Disable e10s for non-Firefox Gecko users.

https://reviewboard.mozilla.org/r/191648/#review197376

Blake and I talked and we agreed to make * both * changes here. Let's land this one on this bug, and follow-up on a separate one to also change the default value on the GetBoolPref function call to be false.
Attachment #8920705 - Flags: review+
Pushed by felipc@gmail.com:
https://hg.mozilla.org/integration/autoland/rev/8592e9905565
Disable e10s for non-Firefox Gecko users. r=Felipe
https://hg.mozilla.org/mozilla-central/rev/8592e9905565
Status: NEW → RESOLVED
Closed: 2 years ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 58
Push from comment 5 resolved the regression. Thanks a lot!

== Change summary for alert #10134 (as of October 23 2017 19:52 UTC) ==

Improvements:

  7%  remote-nytimes summary android-7-1-armv8-api16 opt      1,236.06 -> 1,151.15
  6%  remote-nytimes summary android-4-4-armv7-api16 opt      1,905.55 -> 1,784.18

For up to date results, see: https://treeherder.mozilla.org/perf.html#/alerts?id=10134
You need to log in before you can comment on or make changes to this bug.