Open Bug 1410380 Opened 2 years ago Updated 1 year ago

Add automated test for "Top Stories - Enable"

Categories

(Firefox :: New Tab Page, enhancement, P3)

enhancement

Tracking

()

UNCONFIRMED
Tracking Status
firefox57 --- wontfix
firefox58 --- wontfix

People

(Reporter: icrisan, Unassigned)

References

(Blocks 1 open bug)

Details

testrail link: https://testrail.stage.mozaws.net/index.php?/cases/view/76191

Preconditions:
"browser.search.region" is set to "US" in about:config.
Open the browser and go to A-S New Tab page.

Steps:
1. Observe Top Stories section.

Expected results:
Top Stories section is displayed under Top Sites.
Top Stories section title is bolded.
In line with the title, in the right side there is a "?" button.
Under the title there are 3 tiles
Under the tiles there is the "Popular Topics" area.
In the right side of the Popular Topics area, there is the "View More Stories" button with an right arrow.
Component: General → Activity Streams: Newtab
Product: Core → Firefox
Summary: Top Stories - Enable → Add automated test for "Top Stories - Enable"
Priority: -- → P3
Testing top stories with mochitests would require network access which is not possible. As an alternative: top stories and highlights sections are similar so testing for the other would cover both.
Status: NEW → RESOLVED
Closed: 2 years ago
Resolution: --- → WONTFIX
Status: RESOLVED → UNCONFIRMED
Ever confirmed: false
Resolution: WONTFIX → ---
Severity: normal → enhancement
Because i have a problem of wiews for android with app firefox ?

Thanks

Mario

http://www.riparazionepcnapoli.it/sviluppo-siti-internet/
Component: Activity Streams: Newtab → New Tab Page
You need to log in before you can comment on or make changes to this bug.