Closed Bug 1410415 Opened 2 years ago Closed 2 years ago

Set a sandboxName on the WebExtensions Content Script sandboxes

Categories

(WebExtensions :: General, enhancement, P3)

enhancement

Tracking

(firefox58 verified, firefox59 verified)

VERIFIED FIXED
mozilla58
Tracking Status
firefox58 --- verified
firefox59 --- verified

People

(Reporter: rpl, Assigned: rpl)

Details

Attachments

(2 files)

It would be nice to set the sandboxName on the Sandbox instances related to the WebExtensions Content Scripts (as we are already doing for the other sandboxes created by the WebExtensions internals, http://searchfox.org/mozilla-central/search?q=sandboxName&case=false&regexp=false&path=components%2Fextensions).

By setting an explicit sandboxName (e.g. something that includes "Content Script" and the extension id in it), these sandboxes will be more easily recognizable in the about:memory reports (to be fair the moz-extension url is already visible in the memory report because it is part of the sandbox principal, nevertheless including the extension.id would make it easier to recognize which is the extension that owns that moz-extension url).
Assignee: nobody → lgreco
Status: NEW → ASSIGNED
Priority: -- → P3
Attachment #8920567 - Flags: review?(mixedpuppy)
Comment on attachment 8920567 [details]
Bug 1410415 - Set a sandboxName on the WebExtensions Content Script sandboxes.

https://reviewboard.mozilla.org/r/191578/#review196844
Attachment #8920567 - Flags: review?(mixedpuppy) → review+
Pushed by luca.greco@alcacoop.it:
https://hg.mozilla.org/integration/autoland/rev/474d75b9420f
Set a sandboxName on the WebExtensions Content Script sandboxes. r=mixedpuppy
https://hg.mozilla.org/mozilla-central/rev/474d75b9420f
Status: ASSIGNED → RESOLVED
Closed: 2 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla58
Attached file Bug1410415.zip
I can reproduce this issue on Firefox 57.0 (20171112125346) under Wind 7 64-bit.

In the memory report the “[anonymous sandbox]” is displayed.

This issue is verified as fixed on Firefox 59.0a1 (20171120222519) and Firefox 58.0b4 (20171115114231) under Wind 7 64-bit and Mac OS X 10.13. 

The “Content Script” followed by the id of the extension is displayed in the memory report.

Please see the attached screenshots.
Status: RESOLVED → VERIFIED
Product: Toolkit → WebExtensions
You need to log in before you can comment on or make changes to this bug.