Closed Bug 1410448 Opened 4 years ago Closed 4 years ago

twitter dm's dont work in webrender

Categories

(Core :: Graphics: WebRender, defect)

58 Branch
defect
Not set
normal

Tracking

()

RESOLVED WORKSFORME
Tracking Status
firefox57 --- unaffected
firefox58 --- unaffected

People

(Reporter: steve, Unassigned)

References

Details

Attachments

(1 file)

Attached image dms.png
User Agent: Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:58.0) Gecko/20100101 Firefox/58.0
Build ID: 20171020100426

Steps to reproduce:

When logged into Twitter, clicking "messages" at the top to open my DMs.


Actual results:

It renders fairly poorly; It's supposed to have a modal, but instead, only the modal's text appears. If I click "new message", the modal appears; it's only on the "all DMs" screen.

I've attached a partial screenshot; I can't screenshot the whole page as then I'd be showing personal information.


Expected results:

Modal appears.
Version: 57 Branch → 58 Branch
I forgot to mention above that it's been... a week or so since this started happening? I thought it might be temporary and didn't have time to file then, but it started fairly recently.
I feel like this might be the same bug as we're seeing in the profiler upload dialog.
Whiteboard: [wr-mvp] [triage]
Possibly due to ANGLE being messed up right now.
Depends on: 1410304
Whiteboard: [wr-mvp] [triage]
Whiteboard: [wr-mvp] [triage]
Oh; it looks like a similar thing happens when you look at an individual tweet's page https://twitter.com/stshank/status/921386552088936449

so, no need to be logged in to reproduce that.
Priority: P1 → P2
Whiteboard: [wr-mvp] [triage] → [wr-mvp]
Are you still seeing this in the latest nightly? I tried the STR in comment 0 as well the URL in comment 4 and both seem to render fine for me. OS X, latest nightly with WR enabled.
Flags: needinfo?(steve)
Feel free to reopen if you still see this.
Status: UNCONFIRMED → RESOLVED
Closed: 4 years ago
Resolution: --- → WORKSFORME
Priority: P2 → --
Whiteboard: [wr-mvp]
Sorry for the late response all, but yes, this has been working for me. Thanks so much for the quick turnaround! <3
Flags: needinfo?(steve)
You need to log in before you can comment on or make changes to this bug.