Closed Bug 1410476 Opened 2 years ago Closed 2 years ago

WebRender - paytm.com missing images and forms, makes browser toolbars disappear

Categories

(Core :: Graphics: WebRender, defect, P1)

Unspecified
Linux
defect

Tracking

()

RESOLVED FIXED
Tracking Status
firefox-esr52 --- unaffected
firefox56 --- unaffected
firefox57 --- unaffected
firefox58 --- unaffected

People

(Reporter: yoasif, Assigned: kats)

References

()

Details

(Whiteboard: [wr-mvp])

Attachments

(2 files)

Attached image paytm.png
User Agent: Mozilla/5.0 (X11; Linux x86_64; rv:58.0) Gecko/20100101 Firefox/58.0
Build ID: 20171020100426

Steps to reproduce:

turn on gfx.webrender.enabled
turn on gfx.webrendest.enabled
turn on gfx.webrender.layers-free
turn on gfx.webrender.blob-images
turn on layers.acceleration.force-enabled

1. Navigate to https://paytm.com


Actual results:

A lot of browser chrome disappears; back/forward buttons, addressbar. 

Page is missing images and forms. 


Expected results:

Browser chrome does not disappear, images and forms appear. 

Scrolling down causes other content to appear, and for browser chrome to reappear. Scrolling back up causes the browser chrome to disappear again. 

Saw a report on https://www.reddit.com/r/firefox/comments/77ka47/fonts_dont_render_properly_sometimes_im_using/
Attached video paytm.mp4
Not sure how helpful this is:

15:37.34 INFO: Last good revision: 17a1159f7f4d38777269f00b595096dce6f63d26
15:37.34 INFO: First bad revision: 273f8af59697c9a025043bd050b62ae2f1ba04ec
15:37.34 INFO: Pushlog:
https://hg.mozilla.org/integration/autoland/pushloghtml?fromchange=17a1159f7f4d38777269f00b595096dce6f63d26&tochange=273f8af59697c9a025043bd050b62ae2f1ba04ec

This may just point out that it is a problem with layers-free, since #1389000 was in that push.
Has Regression Range: --- → yes
Has STR: --- → yes
OS: Unspecified → Linux
Version: 58 Branch → Trunk
Whiteboard: [wr-mvp] [triage]
See Also: → 1410977
Priority: P1 → P2
Whiteboard: [wr-mvp] [triage] → [wr-mvp]
Fixed.

 9:51.54 INFO: No more inbound revisions, bisection finished.
 9:51.54 INFO: First good revision: 2fc7e2060d1f66cd9600f6c890578b3a1641738d
 9:51.54 INFO: Last bad revision: fba516dc5620ea600c8cfb09ab018458a57c7bb2
 9:51.54 INFO: Pushlog:
https://hg.mozilla.org/integration/autoland/pushloghtml?fromchange=fba516dc5620ea600c8cfb09ab018458a57c7bb2&tochange=2fc7e2060d1f66cd9600f6c890578b3a1641738d
Status: NEW → RESOLVED
Closed: 2 years ago
Resolution: --- → FIXED
Priority: P2 → P1
Whiteboard: [wr-mvp] → [wr-reserve]
See Also: 1410977
Duplicate of this bug: 1410977
Assignee: nobody → bugmail
Whiteboard: [wr-reserve] → [wr-mvp]
You need to log in before you can comment on or make changes to this bug.