Address Bar retains focus after restoring the previous session

VERIFIED FIXED in Firefox 61

Status

()

defect
P3
normal
VERIFIED FIXED
2 years ago
4 months ago

People

(Reporter: alice0775, Assigned: dao)

Tracking

(Blocks 1 bug)

57 Branch
Firefox 61
Points:
---
Dependency tree / graph
Bug Flags:
in-testsuite +

Firefox Tracking Flags

(firefox-esr52 unaffected, firefox56 unaffected, firefox57- wontfix, firefox58 wontfix, firefox59 wontfix, firefox60 wontfix, firefox61 verified)

Details

Attachments

(2 attachments)

(Reporter)

Description

2 years ago
[Tracking Requested - why for this release]: Break browsing experiences after "Restore Previous Session"

Reproducible : always

Steps To Reproduce:
1. Open web page(e.g. https://developer.mozilla.org/en-US/Add-ons/WebExtensions ) in a 1st tab
2. Exit Firefox and restart Firefox
3. Alt > History > "Restore Previous Session"

Actual Results:
Address Bar steals focus.
Pressing arrow keys does not scroll the page.

Expected Results:
Content area should be focused.
Pressing arrow keys should scroll the page.
(Reporter)

Updated

2 years ago
Keywords: regression
(Reporter)

Updated

2 years ago
Blocks: 1393802
Depends on: ss-reliability
Priority: -- → P3
Whiteboard: [photon-visual][triage]
Doesn't sound overly severe, not tracking.
Too late for 57, mark 57 won't fix.
(Assignee)

Updated

2 years ago
Flags: needinfo?(dao+bmo)
Whiteboard: [photon-visual][triage]
(Assignee)

Updated

a year ago
No longer depends on: ss-reliability
Flags: needinfo?(dao+bmo)
(Assignee)

Updated

a year ago
Flags: needinfo?(dao+bmo)
Too late for a patch for 59 and likely for 60 but we can still take a patch for 61.
(Assignee)

Updated

a year ago
Assignee: nobody → dao+bmo
Status: NEW → ASSIGNED
Flags: needinfo?(dao+bmo)
Keywords: regression
OS: Windows 10 → All
Hardware: Unspecified → All
Summary: Address Bar steals focus after doing "Restore Previous Session" → Address Bar retains focus after restore previous session
Comment hidden (mozreview-request)
(Assignee)

Updated

a year ago
Summary: Address Bar retains focus after restore previous session → Address Bar retains focus after restoring the previous session

Comment 6

a year ago
mozreview-review
Comment on attachment 8969889 [details]
Bug 1410591 - Focus the content area when restoring the selected tab.

https://reviewboard.mozilla.org/r/238714/#review244554

Nice and thanks for the test!

::: browser/components/sessionstore/test/browser_focus_after_restore.js:1
(Diff revision 1)
> +/* This Source Code Form is subject to the terms of the Mozilla Public

Can you change this to a CC license, please?

::: browser/components/sessionstore/test/browser_focus_after_restore.js:11
(Diff revision 1)
> +  gURLBar.focus();
> +  is(document.activeElement, gURLBar.inputField, "urlbar is focused before restoring");
> +
> +  await promiseBrowserState({
> +    windows: [
> +      {

nit: I'd prefer this see this struct formatted as:
```js
await promiseBrowserState({
  windows: [{
    tabs: [{
      entries: [{
        url: "http://example.org/", triggeringPrincipal_base64
      }]
    }],
    selected: 1
  }]
});
```

... which looks more compact and legible.
Attachment #8969889 - Flags: review?(mdeboer) → review+
Comment hidden (mozreview-request)
hg error in cmd: hg rebase -s e7ed16a8bc982da5b22986f09e9abd1a8226cb98 -d aac9f21986a7: abort: can't rebase public changeset e7ed16a8bc98
(see 'hg help phases' for details)

Comment 9

a year ago
Pushed by dgottwald@mozilla.com:
https://hg.mozilla.org/integration/mozilla-inbound/rev/a5dad10abab9
Focus the content area when restoring the selected tab. r=mikedeboer

Comment 10

a year ago
bugherder
https://hg.mozilla.org/mozilla-central/rev/a5dad10abab9
Status: ASSIGNED → RESOLVED
Last Resolved: a year ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 61
(Assignee)

Updated

a year ago
Flags: in-testsuite+
(Assignee)

Updated

a year ago
Flags: qe-verify+
(Assignee)

Comment 11

a year ago
Approval Request Comment
[Feature/Bug causing the regression]: bug 1393802
[User impact if declined]: see comment 0
[Is this code covered by automated tests?]: yes
[Has the fix been verified in Nightly?]: no
[Needs manual test from QE? If yes, steps to reproduce]: manual verification might be a good idea despite the test. steps in comment 0.
[List of other uplifts needed for the feature/fix]: /
[Is the change risky?]: no
[Why is the change risky/not risky?]: very straightforward fix
[String changes made/needed]: /
Attachment #8970468 - Flags: approval-mozilla-beta?
I have reproduced this bug on an affected Nightly build (2017-10-20) using STR from comment 0.

I cannot reproduce it anymore on latest Nightly 61.0a1 (2018-04-24) running Win 10 x64, macOS 10.13 and Ubuntu 16.04 x64.

Ni myself as a reminder to verify this on Beta too.
Status: RESOLVED → VERIFIED
Flags: needinfo?(ciprian.georgiu)
Comment on attachment 8970468 [details] [diff] [review]
patch for uplift

At this stage in the cycle, I'd rather let this ride to 61 as it's not a new issue in 60.
Flags: needinfo?(ciprian.georgiu)
Attachment #8970468 - Flags: approval-mozilla-beta? → approval-mozilla-beta-

Updated

4 months ago
Depends on: 1516777
You need to log in before you can comment on or make changes to this bug.