Closed Bug 1410592 Opened 4 years ago Closed 3 years ago

webrender: Incorrect video (wrong color space?) in " GAMES I HATE - Happy Console Gamer" YouTube video

Categories

(Core :: Graphics: WebRender, defect, P3)

Unspecified
Linux
defect

Tracking

()

RESOLVED DUPLICATE of bug 1423795
Tracking Status
firefox56 --- unaffected
firefox57 --- unaffected
firefox58 --- unaffected
firefox59 --- disabled

People

(Reporter: yoasif, Unassigned)

References

(Blocks 1 open bug, )

Details

(Keywords: nightly-community, Whiteboard: [wr-reserve][gfx-noted])

Attachments

(3 files)

User Agent: Mozilla/5.0 (X11; Linux x86_64; rv:58.0) Gecko/20100101 Firefox/58.0
Build ID: 20171020221129

Steps to reproduce:

Saw on https://www.reddit.com/r/firefox/comments/77quqh/fixing_a_video_codec_problem/

turn on gfx.webrender.enabled
turn on gfx.webrendest.enabled
turn on gfx.webrender.layers-free
turn on gfx.webrender.blob-images
turn on layers.acceleration.force-enabled

1. Navigate to https://www.youtube.com/watch?v=WAHBGZn_Kmg&feature=youtu.be&t=93
2. Watch video for a few seconds


Actual results:

The field on the sides of the air strip shows as a solid green color. 


Expected results:

The field on the sides of the air strip should show as striped, with light and dark greens. 

See screenshots. The video plays correctly on the same machine if downloaded using youtube-dl and played with mpv.
Attached image webrender-game.png
Attached image non-webrender-game.png
Nightly 58 x64 20171020221129 de_DE @ Debian Testing (KDE, Radeon RX480)
main profile: gpu process + layers force accel + webrender + webrendest + blob-image + omtp
Confirmed. Only if I disable "webrender", it's looking like in Firefox ESR with different green colors. (Would be great if this had the same root cause as bug 1402067.)
See Also: → 1410597
Summary: Incorrect video (wrong color space?) in " GAMES I HATE - Happy Console Gamer" YouTube video → webrender: Incorrect video (wrong color space?) in " GAMES I HATE - Happy Console Gamer" YouTube video
Reproducible on 57.0b10 with prefs mentioned in Description being disabled. Doesn't seem to be a WebRender problem on my end. Windows 10 64bit Fall Creators Update.
(In reply to smartfon.reddit from comment #4)
> Reproducible on 57.0b10 with prefs mentioned in Description being disabled.
> Doesn't seem to be a WebRender problem on my end. Windows 10 64bit Fall Creators Update.

At least on Linux, this bug seems to be only present with WebRender. (?)
Your case should be bug 1410597 ("See also" of this bug). Maybe they all have the same root cause.
OS: Unspecified → Linux
Version: 58 Branch → Trunk
Whiteboard: [wr-mvp] [triage]
Priority: P3 → P2
Whiteboard: [wr-mvp] [triage] → [wr-mvp]
Priority: P2 → P3
Whiteboard: [wr-mvp] → [wr-reserve]
Duplicate of this bug: 1410597
Whiteboard: [wr-reserve] → [wr-reserve][gfx-noted]
mozregression --find-fix --bad 2017-10-21 --good 2018-01-10 --pref layers.acceleration.force-enabled:true gfx.webrender.enabled:true gfx.webrender.blob-images:true image.mem.shared:true layout.display-list.retain:false startup.homepage_welcome_url:"https://www.youtube.com/watch?v=WAHBGZn_Kmg&feature=youtu.be&t=93"
> 8:15.29 INFO: First good revision: 76e2381ca4d1ae6548500558ab3783b42c4878d6
> 8:15.29 INFO: Last bad revision: 1514dd91f40e7009b736a7d74f209b5217fee3f8
> 8:15.29 INFO: Pushlog:
> https://hg.mozilla.org/integration/mozilla-inbound/pushloghtml?fromchange=1514dd91f40e7009b736a7d74f209b5217fee3f8&tochange=76e2381ca4d1ae6548500558ab3783b42c4878d6

> 76e2381ca4d1	sotaro — Bug 1423795 - Set correct YUVColorSpace for video if possible r=nical
Status: NEW → RESOLVED
Closed: 3 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1423795
You need to log in before you can comment on or make changes to this bug.