`./mach bootstrap` -> building 'mercurial.cext.base85' -> error: Unable to find vcvarsall.bat

RESOLVED DUPLICATE of bug 1405597

Status

()

Core
Build Config
RESOLVED DUPLICATE of bug 1405597
a month ago
a month ago

People

(Reporter: gerald, Unassigned)

Tracking

Trunk
x86_64
Windows 10
Points:
---

Firefox Tracking Flags

(firefox58 affected)

Details

(Reporter)

Description

a month ago
After reviving an old PC, and installing VS 2017 (VS 2015 is still installed too), I'm unable to do a `./mach bootstrap` for Desktop:
> Running pip to ensure Mercurial is up-to-date...
> Collecting Mercurial
>   Using cached mercurial-4.3.3.tar.gz
> Installing collected packages: Mercurial
>   Found existing installation: mercurial 4.2.2
>     Uninstalling mercurial-4.2.2:
>       Successfully uninstalled mercurial-4.2.2
>   Running setup.py install for Mercurial ... error
>     Complete output from command c:\mozilla-build\python\python.exe -u -c "import setuptools, tokenize;__file__='c:\\users\\gerald\\appdata\\local\\temp\\pip-build-ipv2wx\\Mercurial\\setup.py';f=getattr(tokenize, 'open', open)(__file__);code=f.read().replace('\r\n', '\n');f.close();exec(compile(code, __file__, 'exec'))" install --record c:\users\gerald\appdata\local\temp\pip-wxfj2_-record\install-record.txt --single-version-externally-managed --compile:
>     c:\mozilla-build\python\lib\distutils\dist.py:267: UserWarning: Unknown distribution option: 'python_requires'
>       warnings.warn(msg)
>     running install
>     running build
>     running build_mo
>     warning: hgbuildmo: could not find msgfmt executable, no translations will be built
> 
>     running build_py
>     creating build
>     creating build\lib.win-amd64-2.7
>     creating build\lib.win-amd64-2.7\mercurial
>     copying mercurial\ancestor.py -> build\lib.win-amd64-2.7\mercurial
[... lots more "copying" ...]
>     copying mercurial\templates\static\style.css -> build\lib.win-amd64-2.7\mercurial\templates\static
>     running build_ext
>     building 'mercurial.cext.base85' extension
>     error: Unable to find vcvarsall.bat
> 
>     ----------------------------------------
>   Rolling back uninstall of mercurial
> Command "c:\mozilla-build\python\python.exe -u -c "import setuptools, tokenize;__file__='c:\\users\\gerald\\appdata\\local\\temp\\pip-build-ipv2wx\\Mercurial\\setup.py';f=getattr(tokenize, 'open', open)(__file__);code=f.read().replace('\r\n', '\n');f.close();exec(compile(code, __file__, 'exec'))" install --record c:\users\gerald\appdata\local\temp\pip-wxfj2_-record\install-record.txt --single-version-externally-managed --compile" failed with error code 1 in c:\users\gerald\appdata\local\temp\pip-build-ipv2wx\Mercurial\

I followed the instructions from:
https://developer.mozilla.org/en-US/docs/Mozilla/Developer_guide/Build_Instructions/Windows_Prerequisites#Visual_Studio_2017

A MS blog post suggests pip packages should provide "wheels":
https://blogs.msdn.microsoft.com/pythonengineering/2016/04/11/unable-to-find-vcvarsall-bat/

Not sure what to do from here, apart from buying a new PC.
Suggestions? Or is it something that should actually be fixed? I can work on other machines, so I'd be happy to conduct tests on this PC if that helps.

Updated

a month ago
Status: NEW → RESOLVED
Last Resolved: a month ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1405597
You need to log in before you can comment on or make changes to this bug.