A link opening a target window sets the focus to the address bar, not the view area

RESOLVED WORKSFORME

Status

--
minor
RESOLVED WORKSFORME
17 years ago
14 years ago

People

(Reporter: bryceandamy, Assigned: Matti)

Tracking

Trunk
x86
Windows 98

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

17 years ago
From Bugzilla Helper:
User-Agent: Mozilla/4.0 (compatible; MSIE 6.0; Windows 98)
BuildID:    RC1

Thanks for fixing bug #63334 and its duplicates.  This bug fix corrected the 
problem where the address did not show up in the address field on a targetted 
link.  Unfortunately, the fix seems slightly bugged.  Now the address does show 
up properly, but the address bar has the focus, instead of the display area.  
My personal feeling is that the display area should have the focus just as if 
the user had opened a new window, typed in the address, and hit enter.  This 
makes scrolling ith the space bar or pg up/pg down keys easier since there is 
no need to click in the window first.

Reproducible: Always
Steps to Reproduce:
1.find a link that opens a new window (one page: www.free-market.net/news)
2.click the link
3.try to scroll in the new window.

Actual Results:  You can't!  The focus is stuck in the address bar.

Expected Results:  Again, maybe I am mistaken, but Mozilla should have set 
focus to the main display window

I was using Win98, mozilla RC1.  Again, this bug is probably the result of the 
#63334 bugfix.

Comment 1

17 years ago
WORKSFORME Moz1.1 and yesterday's trunk, Win2K.

Bryce Sellers: please check a recent build (1.1) and mark this bug FIXED if this
problem no longer appears.

Comment 2

17 years ago
No response ->WFM
Status: UNCONFIRMED → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → WORKSFORME
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.