[gtk2] Misbehavior of the scrolling bar of "multiple" select object

RESOLVED WORKSFORME

Status

()

Core
XUL
RESOLVED WORKSFORME
16 years ago
16 years ago

People

(Reporter: Michelle Lei, Assigned: blizzard)

Tracking

Trunk
x86
Linux
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

251 bytes, text/html
Details
(Reporter)

Description

16 years ago
This is a gtk2-related bug. 

Steps to reproduce:
1. Find a select object that has more "option" members than pre-set size. 
   The select object also has to allow multiple select. 
2. Highlight the first option. 
3. Scroll down to another option that is initially out of sight and highlight
that option. 

Actual result:
The scroll bar will jump back to the beginning of the option list.
(Reporter)

Comment 1

16 years ago
Simple sample file:
<html><head/>
<body>
<form>
<select size = "10" multiple>
<option> 1
<option> 2
<option> 3
<option> 4
<option> 5
<option> 6
<option> 7
<option> 8
<option> 9
<option> 10
<option> 11
<option> 12
<option> 13
<option> 14
</select>
</form>
</body>
</html>

Blocks: 92033

Comment 2

16 years ago
1) label gtk2 bugs with [gtk2] please
2) do not use XPToolkit/Widgets default owner/qa as a dumping ground for gtk2 
bugs. Please assign these to someone who is doing the work.
Assignee: jaggernaut → michelle.lei
QA Contact: jrgm → michelle.lei
Summary: Misbehavior of the scrolling bar of "multiple" select object → [gtk2] Misbehavior of the scrolling bar of "multiple" select object
(Assignee)

Comment 3

16 years ago
->blizzard@mozilla.org
Assignee: michelle.lei → blizzard

Comment 4

16 years ago
Created attachment 88634 [details]
testcase

create test according to comment #1

Comment 5

16 years ago
but I can not reproduce it using this testcase.

Comment 6

16 years ago
Unable to reproduce.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.