Closed Bug 1410945 Opened 3 years ago Closed 2 years ago

Live Bookmarks are not opened in new tab when browser.tabs.loadBookmarksInTabs is set to true

Categories

(Toolkit :: Places, defect, P5)

57 Branch
defect

Tracking

()

RESOLVED WONTFIX

People

(Reporter: seifert, Unassigned)

References

Details

User Agent: Mozilla/5.0 (X11; Linux x86_64; rv:57.0) Gecko/20100101 Firefox/57.0
Build ID: 20171019140425

Steps to reproduce:

set browser.tabs.loadBookmarksInTabs to true and clicked on live bookmark


Actual results:

bookmark opened in current tab


Expected results:

it should open in new tab as other bookmarks
Component: Untriaged → Places
Product: Firefox → Toolkit
Blocks: 658245
Status: UNCONFIRMED → NEW
Ever confirmed: true
Priority: -- → P3
I've brought this across from #658425 to provide my experience which supports this bug.

I've come here since receiving the update to FF57.

I made the changes to about:config and when I access a bookmark through the bookmarks list (for example Ctrl+Shift+B) then the bookmarked URL opens as expected in a new tab. Great!

However, I have a bookmarks toolbar which sits below the main toolbar with a number of regularly used bookmarks. These include RSS feeds. The links to individual items in the RSS feeds do not act like other URLs and open directly in the current tab rather than in a new tab as expected.

Steps to reproduce with appropriate setting 'true' in about:config

Include RSS feed in Bookmark Toolbar
Select desired RSS feed item.
It opens in current tab not in a new tab as expected.
Priority: P3 → P5
Same problem on Firefox 63 trunk, and this program can't solved via extensions like https://addons.mozilla.org/en-US/firefox/addon/open-bookmarks-in-new-tab/?src=search
Wontfixing because live bookmarks are going away - See Bug 1477667.
Status: NEW → RESOLVED
Closed: 2 years ago
Resolution: --- → WONTFIX
You need to log in before you can comment on or make changes to this bug.