Session restore error though nothing to restore

RESOLVED INCOMPLETE

Status

()

Firefox
Session Restore
RESOLVED INCOMPLETE
29 days ago
29 days ago

People

(Reporter: Henri D/CH, Unassigned)

Tracking

56 Branch
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

29 days ago
User Agent: Mozilla/5.0 (Windows NT 6.1; Win64; x64; rv:56.0) Gecko/20100101 Firefox/56.0
Build ID: 20170926190823

Steps to reproduce:

Close Firefox 56 (×64) normally by closing window or all tabs.
Later on restart Firefox normally.


Actual results:

Upon restart, Firefox 56 (×64) opens a "Restore: Sorry …" window from where the last session can be restored. This independently from the number and contents of the tabs in the last session. This works well (though Ccleaner is running in the background) but is unwanted.


Expected results:

Firefox is configured to open only a new window upon start.
This worked well in all previous versions up to Firefox 55…
-------------------------------------------------------------------
I tried a lot without any success (>20 times close/start). At last, I changed the settings for Firefox start twice, first from open new tab to another option, then back to open new tab. This seems to have resolved the problem. Obviously Firefox 56 did not recognize this start option correctly from the previous Firefox 55 settings, though it was displayed correctly on the screen in the settings tab !
(Reporter)

Comment 1

29 days ago
PS: NO, the bug is NOT resolved ! Firefox started 2-3 times normally with just a new tab, than suddenly again with the nasty "Sorry…" error message.
(Reporter)

Comment 2

29 days ago
Created attachment 8921368 [details]
Sorry, a new tab could not be restored !!??
does the issue happen if you disable all your addons?
Flags: needinfo?(bug)
(Reporter)

Comment 4

29 days ago
Yes, the problem also occurs after disabling all Add-Ons and Plug-ins.
My Add-Ons are old type, mostly not compatible with Multiprocess, thus Multiprocess is not activated.
Flags: needinfo?(bug)

Updated

29 days ago
Component: Untriaged → Session Restore
I'm sorry, but we can't really debug this issue for you without a reproducible scenario.

Please be aware that multi-process will be the only supported mode going forward and I strongly recommend to leave that setting alone. I really hope that there are updated versions for the addons that you use and love.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 29 days ago
Resolution: --- → INCOMPLETE
You need to log in before you can comment on or make changes to this bug.