Closed Bug 1411231 Opened 2 years ago Closed 2 years ago

Disable react/prefer-es6-class eslint option

Categories

(DevTools :: General, enhancement, P2)

All
Unspecified
enhancement

Tracking

(firefox58 fixed)

RESOLVED FIXED
Firefox 58
Tracking Status
firefox58 --- fixed

People

(Reporter: miker, Assigned: miker)

References

Details

Attachments

(1 file)

Whilst we are in the process of upgrading to ES6 classes we should disable react/prefer-es6-class
Comment on attachment 8921432 [details]
Bug 1411231 - Disable react/prefer-es6-class eslint option

https://reviewboard.mozilla.org/r/192456/#review197644

::: devtools/.eslintrc.js:60
(Diff revision 1)
>      "react/no-danger": "error",
>      "react/no-did-mount-set-state": "error",
>      "react/no-did-update-set-state": "error",
>      "react/no-direct-mutation-state": "error",
>      "react/no-unknown-property": "error",
> -    "react/prefer-es6-class": ["error", "never"],
> +    "react/prefer-es6-class": ["off", "always"],

I'm guessing we'll want to turn that back on once all components are classes, right?
Attachment #8921432 - Flags: review?(pbrosset) → review+
Comment on attachment 8921432 [details]
Bug 1411231 - Disable react/prefer-es6-class eslint option

https://reviewboard.mozilla.org/r/192456/#review197660

::: devtools/.eslintrc.js:60
(Diff revision 1)
>      "react/no-danger": "error",
>      "react/no-did-mount-set-state": "error",
>      "react/no-did-update-set-state": "error",
>      "react/no-direct-mutation-state": "error",
>      "react/no-unknown-property": "error",
> -    "react/prefer-es6-class": ["error", "never"],
> +    "react/prefer-es6-class": ["off", "always"],

Yes, that would be https://bugzil.la/1411263
Pushed by mratcliffe@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/b627cabbeec9
Disable react/prefer-es6-class eslint option r=pbro
https://hg.mozilla.org/mozilla-central/rev/b627cabbeec9
Status: NEW → RESOLVED
Closed: 2 years ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 58
Blocks: 1411904
No longer depends on: 1411904
Duplicate of this bug: 1411263
Product: Firefox → DevTools
You need to log in before you can comment on or make changes to this bug.