Closed Bug 1411330 Opened 4 years ago Closed 1 year ago

Crash in java.lang.IllegalStateException: at org.mozilla.gecko.telemetry.stores.TelemetryJSONFilePingStore.lockAndReadJSONFromFile(TelemetryJSONFilePingStore.java)

Categories

(Firefox for Android Graveyard :: General, defect, P3)

defect

Tracking

(firefox62 affected, firefox63 affected, firefox64 unaffected)

RESOLVED INCOMPLETE
Tracking Status
firefox62 --- affected
firefox63 --- affected
firefox64 --- unaffected

People

(Reporter: mcomella, Unassigned)

References

Details

(Keywords: crash, regressionwindow-wanted)

Crash Data

This bug was filed from the Socorro interface and is 
report bp-89e745c9-4ff4-42ed-8908-ef4b90171024.
=============================================================
java.lang.IllegalStateException: Expected file to exist but got exception in thread: IntentService[GeckoTelemetryUploadSerWorker]. File info - existence: true, can write: false, size: 739.
	at org.mozilla.gecko.telemetry.stores.TelemetryJSONFilePingStore.lockAndReadJSONFromFile(TelemetryJSONFilePingStore.java:242)
	at org.mozilla.gecko.telemetry.stores.TelemetryJSONFilePingStore.getAllPings(TelemetryJSONFilePingStore.java:171)
	at org.mozilla.gecko.telemetry.stores.TelemetryJSONFilePingStore.getAllPings(TelemetryJSONFilePingStore.java:66)
	at org.mozilla.gecko.telemetry.TelemetryUploadService.uploadPendingPingsFromStore(TelemetryUploadService.java:99)
	at org.mozilla.gecko.telemetry.TelemetryUploadService.onHandleIntent(TelemetryUploadService.java:82)
	at android.app.IntentService$ServiceHandler.handleMessage(IntentService.java:66)
	at android.os.Handler.dispatchMessage(Handler.java:102)

- Top crasher #15 in 57.0b9.
- This *only* happens on the Fairphone FP2. Perhaps, by default or by user customization, the phone disables file access but enables the storage permission.

We crash because we carry the assumption that we can write to disk and crashing allows us to uncover bugs (e.g. we accidentally change the file mode to read-only). However, that assumption is incorrect in certain cases like this one. We can write a workaround to help these users or continue crashing/wontfix as a preventative measure for our larger user base.
NI Joe and Wesly to help prioritize this
Flags: needinfo?(wehuang)
Flags: needinfo?(jcheng)
Priority: -- → P1
Status: NEW → RESOLVED
Closed: 4 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1314835
Although the reporter from bug 1413354 mentioned that these crashes started only from Beta 57, so it might also be a slightly different issue.
Status: RESOLVED → REOPENED
Resolution: DUPLICATE → ---
See Also: → 1314835
Duplicate of this bug: 1413354
Let me know if I can provide any more information that help you solve this bug, since I can reproduce it (and yet found a workaround, see bug 1413354).
Or could it be that I was the only user having this problem? I could imagine there aren't many Fairphone FP2 owners that use Firefox Beta, or are there?
(In reply to Claas Augner [:claas] from comment #5)
> Let me know if I can provide any more information that help you solve this
> bug, since I can reproduce it (and yet found a workaround, see bug 1413354).
> Or could it be that I was the only user having this problem? I could imagine
> there aren't many Fairphone FP2 owners that use Firefox Beta, or are there?

Claas, thanks for the detailed information already! Are there any non-standard (to Android) preferences that you've enabled on the Fairphone FP2, or that the system provides by default? Similarly, are there any other customizations you've made that could be related?

It's unexpected that we can read from the file in our data directory but don't have permission to write to it – I don't think that normally happens in Android.
Flags: needinfo?(mozilla)
Michael, sorry for delay. I can not recall having made any non-standard preferences on my Fairphone FP2 or any system defaults that would explain this unexpected permission situation.

I did however have some issues with my phone (such as battery drain in conjunction with an usual CPU load as well as filesystem corruptions on the inserted microSD card). This lead me to migrate from the default operating system, Fairphone OS (Android 6.0), to Lineage OS 14.1 (Android 7.1.2) last weekend. I could not reproduce the problem in Firefox Beta afterwards, have then migrated to Nightly and didn't experience any problems there either.
Flags: needinfo?(mozilla)
#31 in 57.0.4 top crasher while not seen in 58.0b14 and 59.0a1 top 50 today. Lower priority.
Flags: needinfo?(wehuang)
Priority: P1 → P3
Hi Nevin,

Is the regressionwindow-wanted flag still valid, taking into consideration Comment 7?

Thanks!
Flags: needinfo?(cnevinchen)
Hi Susheel
Please advise.
Flags: needinfo?(cnevinchen) → needinfo?(sdaswani)
Marcia is this a high priority crash?
Flags: needinfo?(sdaswani)
Flags: needinfo?(mozillamarcia.knous)
Flags: needinfo?(jcheng)
(In reply to :sdaswani only needinfo from comment #11)
> Marcia is this a high priority crash?

It is still around, but in relatively low volume. I wouldn't spend any resources on it unless volume increases.
Flags: needinfo?(mozillamarcia.knous)

This had a small spike in the builds from 1-3, but it was only two installs.

We have completed our launch of our new Firefox on Android. The development of the new versions use GitHub for issue tracking. If the bug report still reproduces in a current version of [Firefox on Android nightly](https://play.google.com/store/apps/details?id=org.mozilla.fenix) an issue can be reported at the [Fenix GitHub project](https://github.com/mozilla-mobile/fenix/). If you want to discuss your report please use [Mozilla's chat](https://wiki.mozilla.org/Matrix#Connect_to_Matrix) server https://chat.mozilla.org and join the [#fenix](https://chat.mozilla.org/#/room/#fenix:mozilla.org) channel.
Status: REOPENED → RESOLVED
Closed: 4 years ago1 year ago
Resolution: --- → INCOMPLETE
Product: Firefox for Android → Firefox for Android Graveyard
You need to log in before you can comment on or make changes to this bug.