Webrender doesn't repaint Google sheets correctly after column/row resize

RESOLVED WORKSFORME

Status

()

Core
Graphics: WebRender
RESOLVED WORKSFORME
26 days ago
20 days ago

People

(Reporter: mostlygeek, Unassigned)

Tracking

(Blocks: 1 bug)

58 Branch
x86
Mac OS X
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(firefox57 unaffected, firefox58 unaffected)

Details

(Whiteboard: [gfx-noted])

Attachments

(1 attachment)

(Reporter)

Description

26 days ago
Created attachment 8921608 [details]
webrender-googlesheets-bug.png

Tested on Nightly 58 (2018-Oct-24). 

With WebRender disabled everything works as expected. 

With WebRender on: 

- when resizing a column or row, the rest of the sheet does not update
- switching between sheets will force a repaint then it will look correct
- see attached screenshot of problem after resizing a column
This is probably caused by the same problem as bug 1401609.

Updated

26 days ago
Whiteboard: [wr-mvp] [triage]
Lets revisit this when bug 1401609 lands.
Blocks: 1386665
status-firefox57: --- → unaffected
status-firefox58: affected → unaffected
Depends on: 1401609
Priority: -- → P3

Updated

24 days ago
Priority: P3 → P2
Whiteboard: [wr-mvp] [triage] → [wr-mvp]

Updated

24 days ago
Whiteboard: [wr-mvp] → [wr-mvp][gfx-noted]
This appears to be fixed in the latest Nightly. Benson, can you confirm?
Flags: needinfo?(bwong)
(Reporter)

Comment 4

20 days ago
Looks fixed for me!
Status: NEW → RESOLVED
Last Resolved: 20 days ago
Flags: needinfo?(bwong)
Resolution: --- → FIXED

Updated

20 days ago
Priority: P2 → --
Resolution: FIXED → WORKSFORME
Whiteboard: [wr-mvp][gfx-noted] → [gfx-noted]
You need to log in before you can comment on or make changes to this bug.