Closed Bug 141156 Opened 18 years ago Closed 17 years ago

incorrect address shown when asking for a password

Categories

(SeaMonkey :: MailNews: Account Configuration, defect, trivial)

x86
Windows NT
defect
Not set
trivial

Tracking

(Not tracked)

RESOLVED DUPLICATE of bug 212937

People

(Reporter: asensi2, Assigned: racham)

Details

Attachments

(1 file)

From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; WinNT4.0; en-US; rv:1.0rc1) Gecko/20020417
BuildID:    2002041711

* The context is:
You have an e-mail account like “user@domain.com“
Your pop server is “pop.domain.com”
In Mozilla your account name is “user”
AND the “user name”, that the server asks you, is “user@domain.com“ (yes, with the “@”)

* When you click “get mail” it says:
“Enter your password for user@domain.com@pop.domain.com”
It should say
“Enter your password for user@domain.com”

* Other contexts:
If your “user name” was “user;domain.com“ you would have 
“Enter your password for user;domain.com@pop.domain.com”

It should be very easy to fix.  

Reproducible: Always
Steps to Reproduce:
1. Put this configuration or similar, don't write a password there, it has to ask you.
2. Click "Get Mail"
I have noticed this also.
Reporter - is this still a problem? If not, please close the bug!
Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.4) Gecko/20030624

It still works the way described in bug report because mozilla uses
"<pop-user-name>@<pop-host-name>" in the mentioned dialog while <pop-user-name>
is often a complete email address these days. Correct solution is "user
<pop-user-name> at host <pop-host-name>" although this would look slightly
confusing too (but, again, correct).

It all lives in localMsgs.properties:

## @name POP3_ENTER_PASSWORD_PROMPT
## @loc None
# LOCALIZATION NOTE(4016): Do not translate the word "%1$s@%2$s" below.
# Place the word "%1$s@%2$s" where email account name should appear (i.e.
john.smith@example.org)
4017=Enter your password for %1$s@%2$s:

## @name POP3_PREVIOUSLY_ENTERED_PASSWORD_IS_INVALID_ETC
## @loc None
# LOCALIZATION NOTE(4016): Do not translate the word "%s" below. It will receive
the message returned by the server.
# Do not translate "%.100s@%.100s". It will receive the email account name.
4018=Please enter a new password for user %.100s@%.100s:
duping this to a younger but more active bug (with patch)...

*** This bug has been marked as a duplicate of 212937 ***
Status: UNCONFIRMED → RESOLVED
Closed: 17 years ago
Resolution: --- → DUPLICATE
Product: Browser → Seamonkey
Comment on attachment 8921341 [details]
Bug 141156 - Set MOZ_DEBUG globally as both a CONFIG and a #define.

Wrong bug
Attachment #8921341 - Flags: review?(mshal)
Comment on attachment 8921341 [details]
Bug 141156 - Set MOZ_DEBUG globally as both a CONFIG and a #define.

PEBKAC
Attachment #8921341 - Flags: review?(mshal)
You need to log in before you can comment on or make changes to this bug.