news before wizard causes window to loop

VERIFIED WORKSFORME

Status

MailNews Core
Networking: NNTP
--
major
VERIFIED WORKSFORME
16 years ago
9 years ago

People

(Reporter: Erik Neuenschwander, Assigned: (not reading, please use seth@sspitzer.org instead))

Tracking

Trunk
PowerPC
Mac OS X

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

16 years ago
Starting this in news networking, since it is a news URL.  But having zero news
accounts is required to repro.

Build: 1.0 branch 2002-04-27-05

1) don't have any news accounts and probably don't have "news" be a valid server
from where you sit.
2) enter nntp:netscape.public.mozilla.jobs or the given URL, or any news or nntp
URL without a server into the URL bar of the browser.
3) click OK in reponse to the dialog/sheet asking if you want to subscribe

Expected: I guess the new account wizard should come up.

Actual: The cursor flashes over to busy and back and the throbber repeatedly
kicks off its animation loop.  This goes on for as long as I waited (15 secs or
so).  You have to close the window or tab to regain use of your browser.

Once you've done this, two things are true
1) if you type that URL into the location bar again, you're considered
subscribed and enter the loop right away
2) an account to the server "news" has been created in your mailnews settings,
with minimal data.  That account is subscribed to the group you used in the test.

Comment 1

16 years ago
Works for me. 2002-04-28-08.
This also worksforme using the 2002-05-17-08 trunk Mac OS X 10.1.4 build,
although I must reveal that for all of us inside of Netscape, 'news' is really a
hostname that resolves to news.mcom.com, so I am not _exactly_ doing the same steps.

Ian, when you tried to reproduce this, is 'news' a valid server for you?
Sorry, still can't reproduce this.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → WORKSFORME
I just tried this again with the 6-10-2002 build Mac OS X 10.1.5 - no luck in
reproducing.
Status: RESOLVED → VERIFIED
Product: MailNews → Core
Product: Core → MailNews Core
You need to log in before you can comment on or make changes to this bug.