Closed Bug 1411644 Opened 3 years ago Closed 3 years ago

Intermittent content process leak of 1 CancelableRunnable in crash tests

Categories

(Core :: XPCOM, defect, P3)

defect

Tracking

()

RESOLVED DUPLICATE of bug 1416927

People

(Reporter: mccr8, Unassigned)

References

(Blocks 1 open bug)

Details

(Keywords: memory-leak, Whiteboard: [MemShrink])

Looking at the log, the content process, for two different runs, was created during dom/base/test/chrome/test_bug1209621.xul so maybe this will be easy to reproduce. I see this on Linux, but not Linux64 or OSX.
Keywords: mlk
Priority: -- → P3
Whiteboard: [MemShrink]
This leak is actually intermittent, despite my hitting it twice on two runs of crash tests, apparently in the same tests.
https://treeherder.mozilla.org/#/jobs?repo=try&revision=900bdb32b890d45ec07404728348d0e550bfa6a1

It also showed up in this run in bc14, again on Linux32:
https://treeherder.mozilla.org/#/jobs?repo=try&revision=f37778db9f571857eeb86b4d0044a44756b56ec7
Depends on: 1410209
With my patches for bug 1410209, the leak now shows up as... RunnableFunction, which is not much more useful.
(In reply to Andrew McCreight [:mccr8] from comment #2)
> With my patches for bug 1410209, the leak now shows up as...
> RunnableFunction, which is not much more useful.

The next step is clearly a cross-platform implementation of lambda introspection.  *ducks*
nsMainThreadPtrHolder<>, which is a similar helper class, simple requires that you pass in a string for the name.
A better example of another class that requires you pass in a name is RunnableFunction. Yes, there are two.

This mName thing seems to work pretty well. My main concern is that it essentially mashes the random string people pass into the runnables into a global namespace used by the leak checker. It could be annoying for people to deal with.
Summary: Content process leak of 1 CancelableRunnable in crash tests → Intermittent content process leak of 1 CancelableRunnable in crash tests
Status: NEW → RESOLVED
Closed: 3 years ago
Resolution: --- → INCOMPLETE
Once bug 1410209 and bug 1411259 have landed, this will show up as an intermittent leak, and hopefully I can figure it out then.
Resolution: INCOMPLETE → DUPLICATE
Duplicate of bug: 1416927
You need to log in before you can comment on or make changes to this bug.