Closed Bug 1411645 Opened 2 years ago Closed 2 years ago

Shapes highlighter: resize on one dimension in transform mode.

Categories

(DevTools :: Inspector, defect)

defect
Not set

Tracking

(firefox59 verified, firefox61 verified, firefox62 verified)

VERIFIED FIXED
Firefox 59
Tracking Status
firefox59 --- verified
firefox61 --- verified
firefox62 --- verified

People

(Reporter: mpark, Assigned: mpark)

References

(Blocks 1 open bug)

Details

(Whiteboard: [designer-tools])

Attachments

(1 file)

In the CSS shapes highlighter, you should be able to resize shapes just horizontally or vertically using markers placed on each edge of the bounding box in transform mode. This would be applicable to polygons, ellipses, and insets, but for insets, it would be identical to the behaviour of the highlighter in non-transform mode.
Whiteboard: [designer-tools]
Comment on attachment 8925103 [details]
Bug 1411645 - Shapes highlighter: resize on one axis in transform mode for polygon and ellipse.

https://reviewboard.mozilla.org/r/196342/#review202186

::: devtools/client/inspector/test/browser_inspector_highlighter-cssshape_06.js:134
(Diff revision 1)
>      isnot(seBB.width, swBB.width, `${shape} width reduced after se scale`);
>      isnot(seBB.height, swBB.height, `${shape} height reduced after se scale`);
>    }
>  }
>  
> +function* testOneDimScale(testActor, helper) {

I think you should move this to a different test. This one is getting quite long and might cause timeout when our CI gets slow.
Attachment #8925103 - Flags: review?(pbrosset) → review+
Keywords: checkin-needed
Pushed by ryanvm@gmail.com:
https://hg.mozilla.org/integration/autoland/rev/6981bc3a8091
Shapes highlighter: resize on one axis in transform mode for polygon and ellipse. r=pbro
Keywords: checkin-needed
Backed out (Bug 1411645) for eslint failures /gecko/devtools/server/actors/highlighters/shapes.js:1904

Backout: https://hg.mozilla.org/integration/autoland/rev/cfbdb1dc35cd8071cb97bcdf0deeaabaa1e33bea 

Push with failures: https://treeherder.mozilla.org/#/jobs?repo=autoland&revision=6981bc3a8091b9b43bcf124e1c7eee27adc35911

Failure log: https://treeherder.mozilla.org/logviewer.html#?job_id=144387069&repo=autoland&lineNumber=242 

[task 2017-11-13T20:24:40.867Z] Error processing command. Ignoring because optional. (optional:packages.txt:comm/build/virtualenv_packages.txt)
242
[task 2017-11-13T20:32:06.713Z] TEST-UNEXPECTED-ERROR | /builds/worker/checkouts/gecko/devtools/server/actors/highlighters/shapes.js:1904:1 | Line 1904 exceeds the maximum line length of 90. (max-len)
243
[taskcluster 2017-11-13 20:32:07.455Z] === Task Finished ===
Flags: needinfo?(mpark)
Flags: needinfo?(mpark)
Keywords: checkin-needed
Pushed by ryanvm@gmail.com:
https://hg.mozilla.org/integration/autoland/rev/6e02657a32a8
Shapes highlighter: resize on one axis in transform mode for polygon and ellipse. r=pbro
Keywords: checkin-needed
https://hg.mozilla.org/mozilla-central/rev/6e02657a32a8
Status: NEW → RESOLVED
Closed: 2 years ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 59
Hi everyone, i have retested this issue on Windows 10 , Windows 7 , Mac OSx and Linux using the latest version of nightly 62.0a1 (2018-05-28) and i can Confirm it as Fixed.
I will mark it accordingly.
Status: RESOLVED → VERIFIED
Product: Firefox → DevTools
You need to log in before you can comment on or make changes to this bug.