Closed Bug 1411648 Opened 5 years ago Closed 5 years ago

Dark border appears below the Tabbar

Categories

(Firefox :: Theme, defect, P1)

Unspecified
macOS
defect

Tracking

()

VERIFIED FIXED
Firefox 58
Tracking Status
firefox-esr52 --- unaffected
firefox56 --- unaffected
firefox57 --- unaffected
firefox58 --- verified

People

(Reporter: mehmet.sahin, Assigned: dao)

References

Details

(Keywords: regression, Whiteboard: [reserve-photon-visual])

Attachments

(2 files)

Attached image Screenshot
Nightly 58.0a1 (2017-10-25) (64-Bit)
macOS 10.12.6

Steps to reproduce:
1.) Open a new window

Actual: Dark border appears below the Tabbar.

Expected: No dark line should appear below the Tabbar.

This is a regression. A screenshot is attached.

A bisect will follow.
Whiteboard: [photon-visual][triage]
Regression Range:

Good: 2017-10-24-22-03-25
 Bad: 2017-10-25-10-04-49
Dão: May be https://hg.mozilla.org/mozilla-central/rev/f5121cba7d7b ?
Flags: needinfo?(dao+bmo)
(In reply to Mehmet from comment #2)
> Dão: May be https://hg.mozilla.org/mozilla-central/rev/f5121cba7d7b ?

Yep, probably.
Blocks: 1405542
Flags: needinfo?(dao+bmo)
Keywords: regression
Priority: -- → P2
Summary: [Photon] Regression: Dark border appears below the Tabbar → Dark border appears below the Tabbar
Whiteboard: [photon-visual][triage] → [reserve-photon-visual]
Maybe I shouldn't have removed var(--tab-toolbar-navbar-overlap) here:

https://hg.mozilla.org/mozilla-central/rev/f5121cba7d7b#l4.11

The titlebar styling is pretty confusing on Mac...
Duplicate of this bug: 1411676
Duplicate of this bug: 1411666
Assignee: nobody → dao+bmo
Status: NEW → ASSIGNED
Priority: P2 → P1
Comment on attachment 8922289 [details]
Bug 1411648 - Remove leftover z-index and bogus border from the nav bar.

https://reviewboard.mozilla.org/r/193346/#review198576
Attachment #8922289 - Flags: review?(nhnt11) → review+
Pushed by dgottwald@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/60904a2148ce
Remove leftover z-index and bogus border from the nav bar. r=nhnt11
https://hg.mozilla.org/mozilla-central/rev/60904a2148ce
Status: ASSIGNED → RESOLVED
Closed: 5 years ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 58
Flags: qe-verify+
I verified this issue using latest Nightly 58.0a1 and latest Firefox Beta 57.0b14 with Build ID 20171102181127 on Mac OS X 10.12
I will mark this as verified fixed.
Status: RESOLVED → VERIFIED
Flags: qe-verify+
You need to log in before you can comment on or make changes to this bug.