Closed Bug 1411697 Opened 4 years ago Closed 4 years ago

Make sure to SendDocumentChannelCleanup even when mPreferredCachedAltDataType is set

Categories

(Core :: Networking, defect, P2)

58 Branch
defect

Tracking

()

RESOLVED FIXED
mozilla58
Tracking Status
firefox58 --- fixed

People

(Reporter: valentin, Assigned: valentin)

References

Details

(Whiteboard: [necko-triaged])

Attachments

(1 file)

No description provided.
Blocks: 1395233
Comment on attachment 8922052 [details]
Bug 1411697 - Make sure to SendDocumentChannelCleanup even when mPreferredCachedAltDataType is set

https://reviewboard.mozilla.org/r/193052/#review198552

Some description about what this patch does is needed.

::: netwerk/protocol/http/HttpChannelChild.cpp:1103
(Diff revision 1)
>  
>    // DocumentChannelCleanup actually nulls out mCacheEntry in the parent, which
>    // we might need later to open the Alt-Data output stream, so just return here
>    if (!mPreferredCachedAltDataType.IsEmpty()) {
>      mKeptAlive = true;
> +    SendDocumentChannelCleanup(false); // don't clear cache entry

The comment above is no longer true.
Attachment #8922052 - Flags: review?(michal.novotny) → review-
Comment on attachment 8922052 [details]
Bug 1411697 - Make sure to SendDocumentChannelCleanup even when mPreferredCachedAltDataType is set

https://reviewboard.mozilla.org/r/193052/#review198578

::: netwerk/protocol/http/HttpChannelChild.cpp:1101
(Diff revision 2)
>  
>    CleanupBackgroundChannel();
>  
> -  // DocumentChannelCleanup actually nulls out mCacheEntry in the parent, which
> -  // we might need later to open the Alt-Data output stream, so just return here
> +  // If there is a possibility we might want to write alt data to the cache
> +  // entry, we keep the channel alive. We still send the DocumentChannelCleanup
> +  // message, but request that the cache entry be kept by the parent.

The sentence sounds a bit weird. Wouldn't be better "but request the cache entry to be kept by the parent"?
Attachment #8922052 - Flags: review?(michal.novotny) → review+
Pushed by valentin.gosu@gmail.com:
https://hg.mozilla.org/integration/autoland/rev/692541a9f99b
Make sure to SendDocumentChannelCleanup even when mPreferredCachedAltDataType is set r=michal
https://hg.mozilla.org/mozilla-central/rev/692541a9f99b
Status: NEW → RESOLVED
Closed: 4 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla58
Duplicate of this bug: 1395233
You need to log in before you can comment on or make changes to this bug.