Autocomplete should prefer framset over frame when sorting

RESOLVED DUPLICATE of bug 97470

Status

RESOLVED DUPLICATE of bug 97470
17 years ago
10 years ago

People

(Reporter: wd, Assigned: hewitt)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

17 years ago
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.0.0+)
Gecko/20020429
BuildID:    2002042908

Now that autocomplete sorts by access frequency ( bug 78270 ), certain pages
which use framesets are exhibiting unexpected behavior.   In several cases, a
frame is taking priority over the frameset itself and appearing before it in the
autocomplete list.

Reproducible: Always
Steps to Reproduce:
1.Type in "dormcam.mine.nu:8080" in the URLbar
2.Click the green arrow to enter
3.Let it sit on that page for a little bit
4.Go "Home" (or to any other page)
5.Type in "dorm"

Actual Results:  The first autocomplete match is:
"http://dormcam.mine.nu:8080/messages.html"

Expected Results:  The first autocomplete match is:
"http://dormcam.mine.nu:8080"

A frame page should never take priority over the containing frameset, unless the
user manually typed in that page URL.  Since bug 7820 landed, I've noticed
autocomplete listing first several matches for URLs that I have never typed in
myself, nor would I ever want to visit since frames rarely make sense when
viewed separately from the frameset.
OS: Windows 2000 → All
Hardware: PC → All
(Reporter)

Comment 1

17 years ago

*** This bug has been marked as a duplicate of 97470 ***
Status: NEW → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → DUPLICATE
Product: Core → SeaMonkey
You need to log in before you can comment on or make changes to this bug.