Closed Bug 1411747 Opened 2 years ago Closed 2 years ago

"Subscribe" and "Text Encoding" do not have highlights or sub-menus despite an arrow in the Overflow menu

Categories

(Firefox :: Menus, defect, P1)

58 Branch
defect

Tracking

()

RESOLVED FIXED
Firefox 58
Tracking Status
firefox57 --- fixed
firefox58 --- fixed

People

(Reporter: u554753, Assigned: jaws)

References

Details

Attachments

(1 file)

Steps to Reproduce:
1. Open hamburger menu
2. Click "Customize"
3. Move as many items to the overflow menu as you can
4. Open the Overflow menu
5. Mouse over the items in the overflow menu

Expected Result:
The 'Subscribe' and 'Text Encoding' buttons in the menus have highlights and arrows.

Actual Result:
'Subscribe' has a '>' mark but does not navigate to a sub-menu nor has a highlight.
'Text Encoding' has a '>' mark but does not navigate to a sub-menu nor has a highlight.
User Agent:
Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:58.0) Gecko/20100101 Firefox/58.0
Which webpage are you testing with? 'Subscribe' and 'Text Encoding' are not available on about:newtab for example. However, we could make the '>' mark appear disabled and possibly introduce a tooltip that explains why it is disabled.
Flags: needinfo?(gwimberly)
http://www.google.com/

You're right. Text Encoding is available on that website. Is there a suggested webpage to where Subscribe should be enabled?
Flags: needinfo?(gwimberly) → needinfo?(jaws)
The Subscribe button works on http://www.cnn.com/services/rss/
Flags: needinfo?(jaws)
Assignee: nobody → jaws
Status: NEW → ASSIGNED
Priority: -- → P1
Subscribe does indeed work on that website. I agree with Comment 2 that a tooltip would be greatly helpful in explaining why the buttons do not work on certain websites.
(In reply to Grover Wimberly IV [:Grover-QA] from comment #6)
> Subscribe does indeed work on that website. I agree with Comment 2 that a
> tooltip would be greatly helpful in explaining why the buttons do not work
> on certain websites.

I filed bug 1412089 for this.
Comment on attachment 8922428 [details]
Bug 1411747 - Lower the opacity on text and chevrons of disabled items to correspond with their lighter icon.

https://reviewboard.mozilla.org/r/193472/#review198758

Looks good to me, thanks!
Attachment #8922428 - Flags: review?(jhofmann) → review+
Pushed by jwein@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/952db1b95302
Lower the opacity on text and chevrons of disabled items to correspond with their lighter icon. r=johannh
https://hg.mozilla.org/mozilla-central/rev/952db1b95302
Status: ASSIGNED → RESOLVED
Closed: 2 years ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 58
Did this also affect the hamburger menu's 'text encoding' option?

I assume this was tacitly wontfix for 57? Given 1395674 landed on 57, I guess it's affected by this bug...
Flags: needinfo?(jaws)
Yes it did. We could fix this for 57, it is a low risk fix.
Flags: needinfo?(jaws)
Comment on attachment 8922428 [details]
Bug 1411747 - Lower the opacity on text and chevrons of disabled items to correspond with their lighter icon.

Approval Request Comment
[Feature/Bug causing the regression]: bug 1395674
[User impact if declined]: some menuitems will appear enabled/usable but are supposed to be disabled for the site
[Is this code covered by automated tests?]: no
[Has the fix been verified in Nightly?]: no
[Needs manual test from QE? If yes, steps to reproduce]: no
[List of other uplifts needed for the feature/fix]: none
[Is the change risky?]: no
[Why is the change risky/not risky?]: adds two extra CSS rules
[String changes made/needed]: none
Attachment #8922428 - Flags: approval-mozilla-beta?
Comment on attachment 8922428 [details]
Bug 1411747 - Lower the opacity on text and chevrons of disabled items to correspond with their lighter icon.

Recent regression, low risk, Beta57+
Attachment #8922428 - Flags: approval-mozilla-beta? → approval-mozilla-beta+
Duplicate of this bug: 1408255
You need to log in before you can comment on or make changes to this bug.