Update cubeb from upstream to cf5ddc5

VERIFIED FIXED in Firefox 57

Status

()

defect
P2
normal
Rank:
15
VERIFIED FIXED
2 years ago
2 years ago

People

(Reporter: achronop, Assigned: achronop)

Tracking

unspecified
mozilla58
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(firefox57 fixed, firefox58 fixed)

Details

Attachments

(1 attachment)

Pick commits:

cf5ddc5 audiounit: unregister system listeners after failed reinit.
a0f5dc6 audiounit: reinit fail when no media devices (Bug 1409224)
6e2280a Elaborate the build instructions for Windows
7c69071 Disable MSBuild mode in AppVeyor.
ede79a7 os2: disable visibility attribute
c2bd582 audiounit: advance active stream counter earlier in stream init (#367)
ee7c747 Mute test deadlock
57eae36 Use _WIN32 rather than WIN32 in cubeb_utils.h.
871456d CMake: Generate and install CMake config files
Assignee: nobody → achronop
Rank: 15
Priority: -- → P2
Blocks: 1409224, 1409216
Pushed by achronop@gmail.com:
https://hg.mozilla.org/integration/mozilla-inbound/rev/80f6a508d207
Update cubeb from upstream to cf5ddc5. r=padenot,kinetik
https://hg.mozilla.org/mozilla-central/rev/80f6a508d207
Status: NEW → RESOLVED
Closed: 2 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla58
Approval Request Comment
[Feature/Bug causing the regression]:Bug 1405258
[User impact if declined]: Crashes when no media device attached on the system.
[Is this code covered by automated tests?]:No
[Has the fix been verified in Nightly?]:Yes
[Needs manual test from QE? If yes, steps to reproduce]: 
Scenario 1: Playback or WebRTC, request on a system that does not have any media device installed.
Scenario 2: Unplug last media device during audio playback or WebRTC call.
[List of other uplifts needed for the feature/fix]:N/A
[Is the change risky?]:No
[Why is the change risky/not risky?]: It is a small fix. Replace assert check with properly fail and abort. 
[String changes made/needed]:No
Attachment #8923328 - Flags: review?(padenot)
Attachment #8923328 - Flags: approval-mozilla-beta?
Attachment #8923328 - Flags: review?(padenot) → review+
Hi Anthony, is this a low risk change? The size of this change is worrisome. I'd like a second opinion on whether to take it in 57 or not.
Flags: needinfo?(ajones)
See Also: → 1412987
This doesn't happy to the beta branch (but should be easy to fix)

grafting 432451:80f6a508d207 "Bug 1411866 - Update cubeb from upstream to cf5ddc5. r=padenot,kinetik"
merging media/libcubeb/README_MOZILLA
 warning: conflicts while merging media/libcubeb/README_MOZILLA! (edit, then use 'hg resolve --mark')
abort: unresolved conflicts, can't continue
(use 'hg resolve' and 'hg graft --continue')
Flags: needinfo?(achronop)
You try to merge the m-c patch. The right patch for beta is the one attached on the bug. See on the "Attachments" please.
Flags: needinfo?(achronop) → needinfo?(sledru)
ok, sorry, my bad.
Flags: needinfo?(sledru)
No reason to be sorry! Thank you for taking care!
Comment on attachment 8923328 [details] [diff] [review]
Bug 1411866 - Uplift cubeb import to cf5ddc5.

Philipp/Marcia mentioned that this fix has helped on Nightly, that's a good data point, taking it. Beta57+
Attachment #8923328 - Flags: approval-mozilla-beta? → approval-mozilla-beta+
(In reply to Ritu Kothari (:ritu) from comment #6)
> Hi Anthony, is this a low risk change? The size of this change is worrisome.
> I'd like a second opinion on whether to take it in 57 or not.

For the record, it isn't high risk but it also isn't a severe problem.
Flags: needinfo?(ajones)
Duplicate of this bug: 1409216
As Bug 1409224 was verified fixed, the update cubeb from upstream to cf5ddc5 was successful. 

Also note that the scenarios mentioned in Comment 5 were tested when Bug 1409224 was verified.
Status: RESOLVED → VERIFIED
Flags: qe-verify+
You need to log in before you can comment on or make changes to this bug.