Closed Bug 1411886 Opened 2 years ago Closed 2 years ago

Should rebuild the dependent frame's display items in retained display list mode

Categories

(Core :: Layout, enhancement)

enhancement
Not set

Tracking

()

RESOLVED FIXED
mozilla58
Tracking Status
firefox58 --- fixed

People

(Reporter: ethlin, Assigned: ethlin)

Details

Attachments

(1 file)

Style images may come from dependent frames. So we should mark dependent frames as rebuild needed.
Attachment #8922245 - Flags: review?(matt.woodrow)
Attachment #8922245 - Flags: review?(matt.woodrow) → review+
Pushed by ethlin@mozilla.com:
https://hg.mozilla.org/projects/graphics/rev/49aadfe12d73
Rebuild the dependent frame's display items in retained display list mode. r=mattwoodrow
Pushed by ethlin@mozilla.com:
https://hg.mozilla.org/integration/mozilla-inbound/rev/be44e8cd8503
Rebuild the dependent frame's display items in retained display list mode. r=mattwoodrow
Backed out bug 1411860 and bug 1411886 for failing reftests layout/reftests/bugs/409084-1{a,b}.html on OS X:

https://hg.mozilla.org/integration/mozilla-inbound/rev/a402f6926b4b5aa6777282d604a903126ee2610c

Push with failure: https://treeherder.mozilla.org/#/jobs?repo=mozilla-inbound&revision=be44e8cd8503ba234372f7fe3d120607f1f00aea&filter-resultStatus=usercancel&filter-resultStatus=runnable&filter-resultStatus=retry&filter-resultStatus=testfailed&filter-resultStatus=busted&filter-resultStatus=exception
Next push which ran it on more OS X variants: https://treeherder.mozilla.org/#/jobs?repo=mozilla-inbound&revision=6eac731d5c33a24ef8d69a410554f201ab21a9ab&filter-resultStatus=usercancel&filter-resultStatus=runnable&filter-resultStatus=retry&filter-resultStatus=testfailed&filter-resultStatus=busted&filter-resultStatus=exception

Failure log: https://treeherder.mozilla.org/logviewer.html#?job_id=139877411&repo=mozilla-inbound

REFTEST TEST-UNEXPECTED-FAIL | file:///Users/cltbld/tasks/task_1509028499/build/tests/reftest/tests/layout/reftests/bugs/409084-1a.html == file:///Users/cltbld/tasks/task_1509028499/build/tests/reftest/tests/layout/reftests/bugs/409084-1-ref.html | image comparison, max difference: 1, number of differing pixels: 460
REFTEST TEST-UNEXPECTED-FAIL | file:///Users/cltbld/tasks/task_1509028499/build/tests/reftest/tests/layout/reftests/bugs/409084-1b.html == file:///Users/cltbld/tasks/task_1509028499/build/tests/reftest/tests/layout/reftests/bugs/409084-1-ref.html | image comparison, max difference: 1, number of differing pixels: 460
Flags: needinfo?(ethlin)
The failures are caused by another fix. I will land this patch again.

https://treeherder.mozilla.org/#/jobs?repo=try&revision=b5a522c41161a219410362dca1192c850c477f69
Flags: needinfo?(ethlin)
Pushed by ethlin@mozilla.com:
https://hg.mozilla.org/integration/mozilla-inbound/rev/e97bbbe3841f
Rebuild the dependent frame's display items in retained display list mode. r=mattwoodrow
https://hg.mozilla.org/mozilla-central/rev/e97bbbe3841f
Status: NEW → RESOLVED
Closed: 2 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla58
You need to log in before you can comment on or make changes to this bug.