Closed Bug 1411929 Opened 2 years ago Closed 2 years ago

WebExtension popups are not rendered when WebRender is enabled

Categories

(Core :: Graphics: WebRender, defect)

x86_64
Windows 10
defect
Not set

Tracking

()

RESOLVED DUPLICATE of bug 1390741

People

(Reporter: sciguyryan, Unassigned)

References

Details

Hi all.

I noticed this bug a while ago but since WebRender wasn't deemed ready for general testing I didn't report it right away. I have taken a quick look at the various WebRender bugs but I didn't see anyone that matches this. If there is one already out there then please close this one as a duplicate.

With WebRender enabled popup windows generated by WebExtensions do not seem to have their contents rendered. A good example of this is the uBlock and BitWarden WebExtensions. The popup its self does render, but with no contents visible at all.

At the moment this is one of the major obstacles to me testing this as I can't use the various extensions I have installed.

This should be pretty easy to verify and test so I haven't included any screenshots or whatnot.
Windows-only bug: Try to set extensions.webextensions.remote;false. If it's fine then, this is a duplicate of bug 1390741. (Which I assume.)

(Manually enabled OOP webextensions are working fine on Linux, but those in the urlbar don't like my manually enabled GPU process: bug 1406230)
(In reply to Jan Andre Ikenmeyer [:darkspirit] from comment #1)
> Windows-only bug: Try to set extensions.webextensions.remote;false. If it's
> fine then, this is a duplicate of bug 1390741. (Which I assume.)
> 
> (Manually enabled OOP webextensions are working fine on Linux, but those in
> the urlbar don't like my manually enabled GPU process: bug 1406230)

Confirmed, seems to be a duplicate of bug 1390741.

Thanks for spotting that!
Status: NEW → RESOLVED
Closed: 2 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1390741
You need to log in before you can comment on or make changes to this bug.