Closed Bug 1411970 Opened 6 years ago Closed 6 years ago

[Intermittent] Top Stories bookmarked status cannot be removed

Categories

(Firefox :: New Tab Page, defect)

57 Branch
defect
Not set
normal

Tracking

()

VERIFIED FIXED
Firefox 58
Tracking Status
firefox57 --- wontfix
firefox58 --- verified

People

(Reporter: JuliaC, Assigned: andreio)

References

Details

[Affected versions]:
- 57.0b11 build1 (20171023180840)

[Affected platforms]:
- Windows 10 x64
- Ubuntu 16.04 x64
- macOS 10.13

[Steps to reproduce]:
1. Launch Firefox
2. Enable the Top Stories section (if it isn't already) 
3. Choose a random Pocket recommendation and bookmark it using its context menu
4. Reopen its context menu and click the "Remove Bookmark" option
5. Repeat step 4. 

[Expected result]:
- [step3] The chosen top story is properly bookmarked
- [step4] The chosen top story is successfully removed from bookmarks 
- [step5] The "Remove Bookmark" option is replaced by the "Bookmark" option

[Actual result]:
- [step3] The chosen top story is properly bookmarked
- [step4] The chosen top story is successfully removed from bookmarks 
- [step5] The "Remove Bookmark" option is still displayed (see the screencast https://goo.gl/pNKxDf)


[Additional notes]:
- The following error is displayed in the Browser Console https://goo.gl/XQT9kB, due to the fact that the bookmark was successfully removed from the first try
- I haven't been able to reproduce this issue using 58.0a1 (2017-10-25)
- The issue is intermittent and it's reproducible with different top stories
Similar to bug 1404261, fixed by https://github.com/mozilla/activity-stream/pull/3675 and uplifted via bug 1407657.
Assignee: nobody → andrei.br92
Blocks: 1407657
Status: NEW → RESOLVED
Closed: 6 years ago
Resolution: --- → FIXED
See Also: → 1404261
Target Milestone: --- → Firefox 58
Flags: qe-verify+
As I already mentioned in comment 0, I wasn't able to reproduce this issue on Firefox 58 (neither on latest 58.0b13 build1 (20171226085105)). Per comment 1, this bug is considered similar to bug 1404261 (fixed via bug 1407657), that is verified fixed on Firefox 58.
Based on all the above arguments, I will mark this as verified fixed.
Status: RESOLVED → VERIFIED
Flags: qe-verify+
Component: Activity Streams: Newtab → New Tab Page
You need to log in before you can comment on or make changes to this bug.