thread '<unnamed>' panicked at 'failed to insert connection'

RESOLVED DUPLICATE of bug 1410107

Status

()

Core
Audio/Video: cubeb
--
critical
RESOLVED DUPLICATE of bug 1410107
29 days ago
22 days ago

People

(Reporter: Wellington Torrejais da Silva, Unassigned)

Tracking

({crash, stackwanted})

58 Branch
Unspecified
Linux
crash, stackwanted
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [need info 2017-11-02])

(Reporter)

Description

29 days ago
User Agent: Mozilla/5.0 (X11; Linux x86_64; rv:58.0) Gecko/20100101 Firefox/58.0
Build ID: 20171024130124

Steps to reproduce:

I got this problem sometimes, specially when try to open many links together:

+++

thread '<unnamed>' panicked at 'failed to insert connection', /build/firefox-trunk-Kdktft/firefox-trunk-58.0~a1~hg20171024r387821/media/audioipc/server/src/lib.rs:607:16
stack backtrace:
   0: <unknown>
   1: <unknown>
   2: <unknown>
   3: <unknown>
   4: <unknown>
   5: <unknown>
   6: <unknown>
   7: <unknown>
   8: <unknown>
   9: start_thread
  10: clone
Redirecting call to abort() to mozalloc_abort

Crash Annotation GraphicsCriticalError: |[C0][GFX1-]: Receive IPC close with reason=AbnormalShutdown (t=50.6304) Crash Annotation GraphicsCriticalError: |[C0][GFX1-]: Receive IPC close with reason=AbnormalShutdown (t=105.501) [GFX1-]: Receive IPC close with reason=AbnormalShutdown
Crash Annotation GraphicsCriticalError: |[C0][GFX1-]: Receive IPC close with reason=AbnormalShutdown (t=239.027) [Child 4758, Chrome_ChildThread] WARNING: pipe error (3): Conexão fechada pela outra ponta: file /build/firefox-trunk-Kdktft/firefox-trunk-58.0~a1~hg20171024r387821/ipc/chromium/src/chrome/common/ipc_channel_posix.cc, line 353

+++


Actual results:

Crash and browser close, sometimes multiple times.
Crashed on restore too.


Expected results:

No crash or more ways to debug the origin of the problem.

Thanks!

Comment 1

28 days ago
https://developer.mozilla.org/en-US/docs/How_to_get_a_stacktrace_for_a_bug_report
Keywords: crash, stackwanted

Updated

28 days ago
Severity: normal → critical
Component: Untriaged → Graphics
Product: Firefox → Core
(Reporter)

Comment 2

25 days ago
(In reply to Wellington Torrejais da Silva from comment #0)
> User Agent: Mozilla/5.0 (X11; Linux x86_64; rv:58.0) Gecko/20100101
> Firefox/58.0
> Build ID: 20171024130124
> 
> Steps to reproduce:
> 
> I got this problem sometimes, specially when try to open many links together:
> 
> +++
> 
> thread '<unnamed>' panicked at 'failed to insert connection',
> /build/firefox-trunk-Kdktft/firefox-trunk-58.0~a1~hg20171024r387821/media/
> audioipc/server/src/lib.rs:607:16
> stack backtrace:
>    0: <unknown>
>    1: <unknown>
>    2: <unknown>
>    3: <unknown>
>    4: <unknown>
>    5: <unknown>
>    6: <unknown>
>    7: <unknown>
>    8: <unknown>
>    9: start_thread
>   10: clone
> Redirecting call to abort() to mozalloc_abort
> 
> Crash Annotation GraphicsCriticalError: |[C0][GFX1-]: Receive IPC close with
> reason=AbnormalShutdown (t=50.6304) Crash Annotation GraphicsCriticalError:
> |[C0][GFX1-]: Receive IPC close with reason=AbnormalShutdown (t=105.501)
> [GFX1-]: Receive IPC close with reason=AbnormalShutdown
> Crash Annotation GraphicsCriticalError: |[C0][GFX1-]: Receive IPC close with
> reason=AbnormalShutdown (t=239.027) [Child 4758, Chrome_ChildThread]
> WARNING: pipe error (3): Conexão fechada pela outra ponta: file
> /build/firefox-trunk-Kdktft/firefox-trunk-58.0~a1~hg20171024r387821/ipc/
> chromium/src/chrome/common/ipc_channel_posix.cc, line 353
> 
> +++
> 
> 
> Actual results:
> 
> Crash and browser close, sometimes multiple times.
> Crashed on restore too.
> 
> 
> Expected results:
> 
> No crash or more ways to debug the origin of the problem.
> 
> Thanks!

I can't get more information. 
Did you cant help me with baby steps or commands lines for try if more efficiency? 

I still can reproducing this and other errors but is difficulty to find the origin of the problem.
If you know parameter or constants to make debug more verbose, please tell me.

Thanks!
Flags: needinfo?(yfdyh000)

Comment 3

25 days ago
Just https://developer.mozilla.org/en-US/docs/Mozilla/How_to_get_a_stacktrace_for_a_bug_report#Requirements.

Can you find and post the crash IDs from "about:crashes"?
Flags: needinfo?(yfdyh000)
Rust panic in audioipc.
Component: Graphics → Audio/Video
I NI just to bring it in your attention feel free to clear it without any explanation. Please set the priority.
Component: Audio/Video → Audio/Video: cubeb
Flags: needinfo?(kinetik)
Flags: needinfo?(dglastonbury)
OS: Unspecified → Linux
Whiteboard: [need info 2017-10-02]
Whiteboard: [need info 2017-10-02] → [need info 2017-11-02]
Status: UNCONFIRMED → RESOLVED
Last Resolved: 22 days ago
Flags: needinfo?(kinetik)
Flags: needinfo?(dglastonbury)
Resolution: --- → DUPLICATE
Duplicate of bug: 1410107
You need to log in before you can comment on or make changes to this bug.