Thunderbird daily install renames profile name in profiles.ini

RESOLVED WORKSFORME

Status

--
critical
RESOLVED WORKSFORME
a year ago
7 months ago

People

(Reporter: emoore, Unassigned)

Tracking

58 Branch
x86_64
Windows 10

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

a year ago
I had been using Thunderbird version 52.4 under Windows 10 Home x64 (version 1703) with the default profile at C:\Profiles\TB_old .

I installed a daily 64 bit version 58 build (20171026030201) in a different directory and it ran the new account wizard when it started. I expected it to have used the default profile. It turns out it had edited the profiles.ini file from

[General]
StartWithLastProfile=1

[Profile0]
Name=default
IsRelative=1
Path=Profiles/y8v9hwk9.default

[Profile1]
Name=Old TB
IsRelative=0
Path=C:\Profiles\TB_old
Default=1

to

[General]
StartWithLastProfile=1

[Profile0]
Name=default
IsRelative=1
Path=Profiles/y8v9hwk9.default

[Profile1]
Name=Old TB
IsRelative=0
Path=C:\Profiles\tmipnqjm.Old TB
Default=1

and created a copy of the existing default profile at C:\Profiles\tmipnqjm.Old TB. I assume it failed to use it because there were no double quotes in the modified Path= statement. 

Reversing the changes to profiles.ini made by daily got both versions to work.

1. The daily build should not have made a copy of the default profile
2. The daily build should not have modified profiles.ini
3. The code that modified profiles.ini doesn't handle embedded spaces in paths correctly. I don't know if that bug could effect somebody creating a profile normally.

Comment 1

a year ago
Hmm, I'm surprised a profile was copied. TB re-writes profiles.ini all the time, but that should not lead to changed information like was reported here.
Flags: needinfo?(acelists)

Comment 2

a year ago
Could be a new feature in Firefox (m-c). It didn't saw a randomized string part (tmipnqjm.) in the profile path so it added one. We should look if there was such a change in m-c checkins.
Flags: needinfo?(acelists)
Severity: normal → critical
The installer rarely changes, so first observation is I wouldn't expect this to be a new bug.  That said, I tried to find a related bug but not sure I found any in https://mzl.la/2GhQt21 and https://mzl.la/2FwiVjy

I'm not 100% clear on your description. So I'd like to ask a different set of questions.

1. Did contents of Profiles/y8v9hwk9.default change in any way?

2. Did C:\Profiles\TB_old change in any way - contents or folder name?

3. Is C:\Profiles\tmipnqjm.Old TB a copy of TB_old?

4. Have you tested further to see how spaces in profile name behaves more generally?
Flags: needinfo?(emoore)
Summary: 64 bit Thunderbird daily build corrupts profiles.ini → 64 bit Thunderbird daily install corrupts profiles.ini
(Reporter)

Comment 4

11 months ago
Unfortunately I lost the contents of my hard disk 3 weeks ago so I have to rely upon memory and can't retest using the same configuration.

"created a copy of the existing default profile at C:\Profiles\tmipnqjm.Old TB." was referring to the default profile at C:\Profiles\TB_old, not the profile named default.

1. No. Profiles/y8v9hwk9.default was just a stub created when installing Thunderbird.
2. No
3. Yes. I was able to use it "as is" after fixing the error in the path. Later on I also modified that path to use the original profile to verify it was still good. 
4. No. 

I have a new profile that I created 3 weeks ago. I didn't move it from the default location yet. I just installed the daily 61.0a1 x64 build and it found and used the existing profile.
Flags: needinfo?(emoore)
I'm not sure what would have happened here, but I doubt it would have been 64bit related.

I cannot reproduce the issue using 52.9.1 32bit or 62.0a1 64bit, folder names with and without spaces. So perhaps something has changed since your report.  Or perhaps we don't have the full steps to reproduce.

Please reopen the bug if you are able to reproduce.
Status: NEW → RESOLVED
Last Resolved: 7 months ago
Resolution: --- → WORKSFORME
Summary: 64 bit Thunderbird daily install corrupts profiles.ini → Thunderbird daily install renames profile name in profiles.ini
You need to log in before you can comment on or make changes to this bug.