Slow text selection, increased CPU use on about.me page

RESOLVED FIXED

Status

()

Core
Graphics: WebRender
RESOLVED FIXED
24 days ago
6 days ago

People

(Reporter: Asif Youssuff, Unassigned)

Tracking

(Blocks: 1 bug, {nightly-community})

Trunk
x86_64
All
nightly-community
Points:
---

Firefox Tracking Flags

(firefox-esr52 unaffected, firefox56 unaffected, firefox57 unaffected, firefox58 unaffected)

Details

(Whiteboard: [gfx-noted], URL)

(Reporter)

Description

24 days ago
User Agent: Mozilla/5.0 (X11; Linux x86_64; rv:58.0) Gecko/20100101 Firefox/58.0
Build ID: 20171026100047

Steps to reproduce:

turn on gfx.webrender.enabled
turn on gfx.webrender.blob-images
turn on layers.acceleration.force-enabled

1. Navigate to https://about.me/mattiamaestrini
2. (Optional) Select "MATTIA MAESTRINI"


Actual results:

Very high CPU use, fans spin up as soon as page loads.

Text selection is extremely slow (selection takes seconds before highlight appears when dragging across text).


Expected results:

Same behavior as when WebRender is not enabled.
(Reporter)

Updated

24 days ago
status-firefox56: --- → unaffected
status-firefox57: --- → unaffected
status-firefox58: --- → unaffected
status-firefox-esr52: --- → unaffected
Keywords: nightly-community
Version: 56 Branch → Trunk
Nightly 58 x64 20171026100047 de_DE @ Debian Testing (KDE, Radeon RX480, AMD FX(tm)-8150 Eight-Core Processor)
fresh profile: layers.acceleration.force-enabled, gfx.webrender.enabled (also tested: + gfx.webrender.blob-images)

Can't reproduce, everything is fast.
ksysguard shows firefox 2% + Web 1% for ca. 1 second. Afterwards, the "CPU %" column is empty again (=too low).
OS: Unspecified → Linux
Hardware: Unspecified → x86_64

Updated

24 days ago
Whiteboard: [wr-mvp] [triage]
Can confirm this page basically locks up my entire machine on macos. Subsequent visits lock up without doing anything at all.
OS: Linux → All

Updated

24 days ago
Whiteboard: [wr-mvp] [triage] → [wr-mvp][triage][gfx-noted]
Blocks: 1386665
Priority: -- → P3

Updated

21 days ago
Priority: P3 → P2
Whiteboard: [wr-mvp][triage][gfx-noted] → [wr-mvp] [gfx-noted]
I cannot reproduce this in my local MacOS machine.
Priority: P2 → P3
Whiteboard: [wr-mvp] [gfx-noted] → [wr-reserve][gfx-noted]
(Reporter)

Comment 4

6 days ago
Now works for me.

10:38.82 INFO: Narrowed inbound regression window from [ab416cb2, 4c387a97] (3 builds) to [ab416cb2, d64ad998] (2 builds) (~1 steps left)
10:38.82 INFO: No more inbound revisions, bisection finished.
10:38.82 INFO: First good revision: d64ad9981d9bc5834c38c75128d8258c149772a3
10:38.82 INFO: Last bad revision: ab416cb2c8db72b0c153cebe7eac201d141f1ba4
10:38.82 INFO: Pushlog:
https://hg.mozilla.org/integration/autoland/pushloghtml?fromchange=ab416cb2c8db72b0c153cebe7eac201d141f1ba4&tochange=d64ad9981d9bc5834c38c75128d8258c149772a3

Likely fixed by Bug 1414271.
Status: NEW → RESOLVED
Last Resolved: 6 days ago
Resolution: --- → FIXED
Priority: P3 → --
Whiteboard: [wr-reserve][gfx-noted] → [gfx-noted]
You need to log in before you can comment on or make changes to this bug.