Closed Bug 1412265 Opened 5 years ago Closed 5 years ago

Font issues in the messages displayed for empty Highlights and Top Stories sections

Categories

(Firefox :: New Tab Page, defect)

All
Windows 7
defect
Not set
normal

Tracking

()

VERIFIED FIXED
Firefox 59
Tracking Status
firefox57 --- wontfix
firefox58 --- fixed
firefox59 --- verified

People

(Reporter: JuliaC, Assigned: andreio)

References

Details

User Story

https://github.com/mozilla/activity-stream/compare/firefox-58b8...9d0cdf7bf14ccc1a517b4df4a983b5b79f69ae93

Attachments

(1 file)

[Affected versions]:
- 57.0b12 build2 (20171026211016)
- 58.0a1 (2017-10-26) 

[Affected platforms]:
- Windows 7 x64

[Steps to reproduce]:
1. Launch Firefox 
2. Dismiss all the Top Stories and Highlights tiles
3. Inspect the informative messages from each section

[Expected result]:
- The user friendly messages are properly displayed

[Actual result]:
- Font issues can be noticed: some letters are smaller (e.g. "t") or bigger (e.g. "p") than the others - see the screenshot https://goo.gl/pkT6aX
Too late in the cycle to fix.  The text is still legible.
Fixed by https://github.com/mozilla/activity-stream/pull/3813 to be uplifted via bug 1415812.
Assignee: nobody → andrei.br92
Blocks: 1415812
https://hg.mozilla.org/mozilla-central/rev/b4d1db669c93
Status: NEW → RESOLVED
Closed: 5 years ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 59
User Agent  Mozilla/5.0 (Windows NT 6.1; Win64; x64; rv:59.0) Gecko/20100101 Firefox/59.0

I have verified that the issue is no longer reproducible on the latest Nightly 59.0a1 (Build ID: 20171121100129) using Windows 7.
Status: RESOLVED → VERIFIED
Bug 1415812 has been uplifted to 58. We should not mark 58 fixed.
Not entirely sure what caused that status change, but looks like the last several changes were unintended. Just to confirm, this should be 57-wontfix, 58-affected, 59-verified.
Sorry for typo in comment #5. What I meant is bug 1415812 has not been uplifted to 58.
gchang says this bug has missed 58.0b8. It doesn't have a patch with beta approval flag. Please attach the appropriate patch without install.rdf.in changes and request approval ASAP.
Flags: needinfo?(andrei.br92)
Comment on attachment 8933379 [details]
Bug 1412265 - Font issues in the messages displayed for empty Highlights and Top Stories sections.

Approval Request Comment
[Feature/Bug causing the regression]: https://github.com/piatra/activity-stream/commit/9a4d144881a79a0d6851869ff8357dbab6f8e4ab
[User impact if declined]: hard to read text on activity stream page on windows 7
[Is this code covered by automated tests?]: no
[Has the fix been verified in Nightly?]: yes
[Needs manual test from QE? If yes, steps to reproduce]: no
[List of other uplifts needed for the feature/fix]: 
[Is the change risky?]: no
[Why is the change risky/not risky?]: only small css change
[String changes made/needed]:
Flags: needinfo?(andrei.br92)
Attachment #8933379 - Flags: approval-mozilla-beta?
Comment on attachment 8933379 [details]
Bug 1412265 - Font issues in the messages displayed for empty Highlights and Top Stories sections.

https://reviewboard.mozilla.org/r/204302/#review209876
Attachment #8933379 - Flags: review?(usarracini) → review+
Comment on attachment 8933379 [details]
Bug 1412265 - Font issues in the messages displayed for empty Highlights and Top Stories sections.

Fix a font issue. Beta58+.
Attachment #8933379 - Flags: approval-mozilla-beta? → approval-mozilla-beta+
User Story: (updated)
Component: Activity Streams: Newtab → New Tab Page
You need to log in before you can comment on or make changes to this bug.