Download key invalidation not working

RESOLVED INVALID

Status

Socorro
Symbols
RESOLVED INVALID
24 days ago
23 days ago

People

(Reporter: peterbe, Assigned: peterbe)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Assignee)

Description

24 days ago
Created attachment 8922783 [details]
peterbe.zip

Steps to reproduce:

1. Go to localhost:8000/peterbe.pdb/deadbeef123/peterbe.sym (Expect 404)
2. Upload the attached zip
3. Go to localhost:8000/peterbe.pdb/deadbeef123/peterbe.sym (Expect 200, Get 404)
(Assignee)

Updated

24 days ago
Assignee: nobody → peterbe
(Assignee)

Comment 1

23 days ago
Sadly not possible to reproduce locally :(
(Assignee)

Comment 2

23 days ago
Ah. Able to reproduce if I actually use AWS S3 and not minio on localhost:9000.

There seems to be a delay between S3 PUT and S3 ListObjectsV2. 
I put some print statements and can assert that the S3 PUT command did happen (successfully) BEFORE the S3 ListObjectsV2 happened, yet the ListObjectsV2 concluded that the file does not exist. 

So we need a way to tell the cache to "wait a little longer" before it concludes that the file doesn't exist.
(Assignee)

Comment 3

23 days ago
For the record, I tried switching from ListObjectsV2 to HeadObject (in fact I used both) and HeadObject too says it's not there yet.
(Assignee)

Comment 4

23 days ago
Invalid testing. The reason it manifested itself was because the symboldownloader forces the debugID to be uppercase. But I uploaded a fake .zip whose debugID was all hex chars but it was in lowercase. That triggered a mismatch in the "cache key comparisons".
Status: NEW → RESOLVED
Last Resolved: 23 days ago
Resolution: --- → INVALID
You need to log in before you can comment on or make changes to this bug.