Closed Bug 1412297 Opened 2 years ago Closed 2 years ago

Some Android test crashes are caused by aborts, but no reason is logged

Categories

(Firefox for Android :: Testing, defect)

defect
Not set

Tracking

()

RESOLVED FIXED
Firefox 58
Tracking Status
firefox58 --- fixed

People

(Reporter: gbrown, Assigned: gbrown)

References

Details

Attachments

(1 file)

If a test harness job hangs or runs for too long, the harness may abort the job, causing a crash. In these cases, the harness logs the reason for the abort, takes a screenshot, kills Firefox, and collects and reports the crash.

Recently, I see tests failing exactly like this, except the cause of the abort is not logged, and not apparent.

For instance, bug 1412223: A screenshot was taken, the crash was caused by SIGABRT, but there is no sign of a hang or a timeout.
Logs show "mozdevice ERROR" a few seconds earlier.
See Also: → 1319196
A minor tweak to how we wait for the remote browser: I'm hoping the retry will make an infrequent failure practically non-existent. Since failures are typically 60 second timeouts, I am reluctant to retry more than once.

https://treeherder.mozilla.org/#/jobs?repo=try&revision=9364bc567c340ae9ddd680efca67b3b4dc6490db
Attachment #8923911 - Flags: review?(jmaher)
Duplicate of this bug: 1412662
Comment on attachment 8923911 [details] [diff] [review]
retry getTopActivity, explain kill

Review of attachment 8923911 [details] [diff] [review]:
-----------------------------------------------------------------

this looks fairly safe
Attachment #8923911 - Flags: review?(jmaher) → review+
Pushed by gbrown@mozilla.com:
https://hg.mozilla.org/integration/mozilla-inbound/rev/0341d179a4ba
Retry devicemanager getTopActivity once; r=jmaher
https://hg.mozilla.org/mozilla-central/rev/0341d179a4ba
Status: NEW → RESOLVED
Closed: 2 years ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 58
Blocks: 1364750
Duplicate of this bug: 1364750
Duplicate of this bug: 1319196
You need to log in before you can comment on or make changes to this bug.