Closed Bug 1412425 Opened 4 years ago Closed 4 years ago

Developer Tools tab set by HTTPS-E reappears after disabled

Categories

(WebExtensions :: Developer Tools, defect)

56 Branch
x86_64
Linux
defect
Not set
normal

Tracking

(Not tracked)

RESOLVED DUPLICATE of bug 1394750

People

(Reporter: astian, Unassigned)

Details

Extension HTTPS Everywhere can put a "tool" in the Developer Toolbox window.
I don't want to ever see the tab that HTTPS-E puts there (I have no use for it
and it clutters the tab bar).  However even after disabling it, under Toolbox
Options, it keeps re-appearing.

STR:

  1. Bring up Firefox's Developer Tools window (e.g., hitting <C-S-k>).

  2. An "HTTPS Everywhere" tab can be seen.

  3. Go to the "Toolbox Options" pane, by clicking the cog icon.

  4. Under "Developer Tools installed by add-ons" uncheck the box that reads
     "HTTPS Everywhere".

     You should see the tab immediately disappear.  Also, a preference named
     like
       devtools.webext-https-everywhere_eff_org-${SOME_NUMBER}-0-0-devtools-panel.enabled
     and set to "false" is created.

  5. Close the Developer Tools window.

  6. Open it once more.

     The fscking HTTPS-E tab is back in there.

  7. Go to the "Toolbox Options" by clicking the cog.

     The checkbox for HTTPS-E is checked once again.

  8. Fscking uncheck it again.

     You should see the tab disappear again and another preference created as
     before but this time with a different value for ${SOME_NUMBER}.

Environment:
  - Firefox 56 (Debian package: firefox 56.0-2).
  - HTTPS Everywhere 2017.10.24.
:rpl, sounds related to DevTools WebExt?
Flags: needinfo?(lgreco)
Yes it is, and it is a duplicate of Bug 1394750 (and I'm going to add more details about how I'd like to change the behavior of the checkbox created in the devtools preferences panel to properly cover this scenario).

As a side note: in chrome there isn't currently a way to disable the devtools panels created from an extension without disabling the entire extension, and so cross-browser extensions like HTTPS Everywhere (especially when the devtools panel is not the reason why a user installs the extension) should probably provide a way to prevent the panel creation from inside the extension itself (e.g. store their own setting as part of the addon options ui or its browser action, store the user preference in storage.local and then in the invisible extension devtools_page using the stored user preference to decide if the devtools panel should be created).
Status: UNCONFIRMED → RESOLVED
Closed: 4 years ago
Flags: needinfo?(lgreco)
Resolution: --- → DUPLICATE
Duplicate of bug: 1394750
Component: Developer Tools → WebExtensions: Developer Tools
Product: Firefox → Toolkit
Product: Toolkit → WebExtensions
You need to log in before you can comment on or make changes to this bug.